Fastd über IPv6 in D06


#1

Moin Zusammen,
an uns ist gerade folgendes Problem herangetragen worden:

Freifunk-Knoten hängt an einer Fritz!Box per WAN-Port,
an der Fritz!Box ist IPv6 per Dual-Stack aktiviert.

Ist Dualstack in der FB aktiv, funktioniert im FF-Client Netz IPv4 scheinbar nicht mehr,
wird Dualstack in der FB deaktiviert, funktioniert FF wieder sauber.

Es geht unter anderem um den Knoten freifunka42bb0eff636-by-epcan
und lässt sich bei mehreren Knoten nachvollziehen.
Verbunden war der Knoten zu dem Zeitpunkt mit remue_04

Hat da Jemand eine Idee ?


#2

Moin,

klingt so, als ob der Router versucht sich über IPV6 einzuwählen. In der Domäne 06 geht das noch, weil es Fastd ist. In den neuen Domänen wird das gar nicht angeboten, weil der Tunneldigger das nicht kann.

Vermutlich schlägt dabei etwas fehl. Eventuell blockiert dort die FritzBox etwas oder sonst etwas läuft schief.

Bitte mal logread des Knoten hier einstellen. Gerne IP-Adressen entfernen oder mir in einer privaten Nachricht schicken.

Grüße
Matthias


#3

Moin Zusammen,
leider konnten wir den Fehler noch nicht selber beheben. (Nur durch abschalten IPv6 in der Fritz!Box)

Anbei wie von Matthias gewünscht der logread des Knotens:
logread_ff-wml-vb-hei.txt (19,0 KB)

Danke schonmal !


#4

Moin,

im Log ist zu sehen (einfach mal nach fastd suchen und die Treffer durchgehen), dass er sich zwischendurch auch per IPV6 einwählen will.

Wenn das nicht geht, warum auch immer, könntest du erstmal auf rein IPV4 umstellen, indem du nur fest IPV4-Adressen in den Router einträgst.

Das geht über uci set. Eigentlich müsste es auch über IPV6 gehen, ist die Frage, ob es sich lohnt, das zu diagnostizieren, weil L2TP eh kein IPV6 kann.

Grüße
Matthias


#5

Das Problem ist, das es sich mitlerweile um mehrere Knoten mit dem Problem handelt.
Es sind insgesamt ca. 20 Stück. Zugriff habe ich aktuell nur auf einen…

Kann man da eventuell einfacher die Firmware anpassen ?

Auf dem Knoten “mit Zugriff” habe ich WAN6 folgendermaßen deaktiviert:
uci set network.wan6.enabled=0


#6

Oder vielleicht "einfach d06 komplett auf L2TP umstellen, um doppelte Arbeit zu sparn, eine weitere Stadt muss ja on nächster Zeit erstmal eher nicht raus gelöst werden.


#7

Wir können die Vorschläge heute Abend mal diskutieren. Derzeit bisschen Arbeitsüberlastung hier.

@Sandmann88: Ich würde vorschlagen, dass ich mir das heute Abend nochmal anschaue, ob es Serverseitig ein Problem gibt und ansonsten kompilieren wir IPV6 aus der Firmware raus.


#8

Das Problem konnte wie folgt in Domäne 01 nachgestellt werden:

Knoten mit IPv6 only kann keine Verbindung aufbauen.
Knoten mit IPv6 und IPv4 (Fritzbox-Default für 1&1) baut Verbindung automatisch und erfolgreich über IPv4 auf.

Also kurz gesagt, du musst den IPv6-Aufbau nicht explizit unterbinden. Bei IPv6-Fehlern versucht es der Knoten automatisch IPv4.

Priorität hat im Moment die Umstellung auf L2TP, mit der dann ohnehin (leider) nur noch IPv4 möglich ist. Ein Umbauen der aktuellen Firmware ist nicht geplant.

@Sandmann88 klappt der Aufbau über IPv4? Hast du eventuell noch Ports an der FritzBox geblockt?


#9

Mahlzeit zusammen !
Über IPv4 klappt der Aufbau der VPN-Verbindung tadellos.
Ports sollten keine geblockt sein. Wie gesagt, das Problem tritt auf, wenn die FritzBox auch IPv6 macht.

Dann werde ich die weiteren, betrefenden Router mal per Hand anpacken.
Gibt es einen groben Plan, wann auf L2TP umgestellt werden soll ?


#10

Schalt doch mal in dem Router IPV6 einfach ab. Das geht unter erweitert im Konfigurationsmodus.


#11

Werd ich wohl machen müssen. Mein Problem ist nur die Anzahl der Router (ca.25), die Entfernungen und mangelnder Fernzugriff…
Aber wir tun was wir können :wink:


#12

Ich hab das Problem hier gerade auch. Sehr dubios.


#13

Fast alle Knoten sind auf L2TP umgezogen.

Ich hoffe, dass das Problem damit behoben ist.


#14

Dieses Thema wurde automatisch 3 Tage nach der letzten Antwort geschlossen. Es sind keine neuen Nachrichten mehr erlaubt.