2.6.1, feste IP im LAN

Hallo!
Ich habe meinem Freifunkrouter bei der Inbetriebnahme in meinem Heimnetz über das Webinterface eine feste IP (v4) gegeben. Bin mir relativ sicher, Gateway, Netzmaske usw. alles gewissenhaft ausgefüllt zu haben. Nun kriegt der tunneldigger aber irgendwie die Namen nicht aufgelöst:
logread

Sun Oct 1 20:18:51 2017 daemon.err td-client: Failed to resolve hostname ‘domaene07-a.servers.freifunk-muensterland.de’.
Sun Oct 1 20:18:51 2017 daemon.err td-client: Failed to resolve hostname ‘domaene07-b.servers.freifunk-muensterland.de’.
Sun Oct 1 20:18:51 2017 daemon.err td-client: Failed to resolve hostname ‘domaene07-a.servers.freifunk-muensterland.net’.
Sun Oct 1 20:18:51 2017 daemon.err td-client: Failed to resolve hostname ‘domaene07-b.servers.freifunk-muensterland.net’.

Ich hab die Adressen fürs erste einfach in der /etc/hosts eingetragen und jetzt tut es, aber wie kriege ich das weidmännisch konfiguriert? Da das Webinterface aufrufen jedes mal extremer Kletterspaß auf dem Dachboden ist, vorzugsweise per Shell :stuck_out_tongue:

Es ist ein TP-Link TL-WR841N/ND v9 mit v2016.2.6+2.6.1 / gluon-v2016.2.6.

Der Trick mit der hosts Datei würde nur solange funktionieren, wie die IPs hinter den a-/b- Adressen sich nicht ändern.
Die sind gewollt so, damit hier immer Roulette gespielt werden kann. (Andere Gateways den Domänen zuordnen wegen der Lastverteilung)

Hast du auch den DNS-Server eingetragen? Klingt danach, dass der DNS nicht funktioniert oder nicht durchgeht. Firewawll ggf dahinter?

Da wäre ich nun bisschen überfragt, wo die Konfiguration in der ssh zu finden

Tipp:
uci set gluon-setup-mode.@setup_mode[0].configured=‘0’ (Der Wert steht zuvor auf 1,da ja bereits konfiguriert.)
ein “uci commit” noch hinterher und anschließend reboot löst das selbe aus wie Klettern und Reset-Button drücken.

Ich meine, dass WAN-Port in der FF-Firmware im Configmode für Clients auch funktioniert, bin mir aber nicht 100% sicher. Das wäre dann nur kurzes Umstecken am Router/Switch nach Reboot, um da ran zu kommen.

Kann ich morgen ja ansonsten mal an einem Node bei mir testen.

Hi,

hast du auch einen DNS-Server vergeben? Normaler Weise kommt der eben vom DHCP und wenn du das ausschaltest, müsstest du auch einen festen DNS-Server vergeben.

Kann aber auch sein, dass das ein Bug ist.

Grüße
Matthias

Ich hab die Adressen aus der hosts-Datei wieder rausgenommen und in die /etc/resolv.conf statt symlink auf /tmp/resolv.conf meinen lokalen DNS eingetragen und dann tut das (auch nach reboot). Sehe ich das richtig, dass ich dadurch keinen DNS Leak habe, weil sich die Freifunk-Software da irgendwie beim Verbindungsaufbau drum kümmert?

Gluon muss einmal über dienen DNS-Server im Netz die Domain des Gateways, also domaenexx-{a,b}.server.freifunk-muensterland.{de,net} auflösen. Der Rest, also die DNS-Abfragen der Clients im Freifunk, wird natürlich über unsere Gateways geleitet.

Grüße
Matthias

gute Idee an der hab ich nicht gedacht. Kann sein, dass durch die config da automatisch auch was eingetragen wird. Glaube ich aber eher nicht: Bei mir steht folgendes:
search lan
nameserver 127.0.0.1

Dort könnte man auch einfach 8.8.8.8 eingeben.
Aber da der lokale DNS oder einfach der Router, welcher wiederum die DNS des Providers in der Regel nutzt.
Soltle das aber nicht updatefest sein (weiß ich nicht) könnte es natürlich beim Update zum Ausfall des Routers führen, da kein DNS und so keine Verbindung. Früher waren in den Gateway-IPs noch die IP’s der Gateways selbst mit eingetragen.