Admintagebuch - Dokumentation der Admintätigkeiten

Ausfall Domäne 01: Tunneldigger und DHCP-Server auf Rhe und Barristan neu gestartet.

Das Tunneldiggerlog ist voll von solchen Nachrichten:

Tue, 06 Sep 2016 14:02:11 ERROR    Socket error 111 (Connection refused) in tunnel 345!
Tue, 06 Sep 2016 14:02:16 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:02:21 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:02:26 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:02:31 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:02:36 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:02:41 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:02:46 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:02:51 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:02:56 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:03:01 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:03:06 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:03:11 ERROR    Failed to send() control message: Connection refused (111)
Tue, 06 Sep 2016 14:03:11 WARNING  Session with tunnel 345 timed out.
Tue, 06 Sep 2016 14:03:11 INFO     Closing tunnel 345.

Ich habe gerade auf Rhe und dem anderen Gateway von Domäne 01 die Leases-Datei gelöscht. Seitdem kriegt man auch wieder vernünftig eine IP. Vorschlag das immer um 4 Uhr nachts zu tun.

Wordpress auf 4.6.1 akutalisiert wg:

Der Ausrufer scheint jetzt stabil zu sein.
Hier eine aktuelle Statistik:

Gruß,
Holger

Ich musste den Hypervisor von Parad0x neu starten. Die VM war so lange nur pausiert. Die Statistik sieht entsprechend “seltsam” aus. Läuft jedoch wieder problemlos weiter.

Die neue Brokersyntax ist in Ansible implementiert und wird gerade ausgerollt. Die Adressen

domaeneXX-{A,B,C,D}.servers.freifunk-muensterland.de

werden dadurch erreichbar und das @Firmwareteam kann sie in die site.confs einbauen.

Grüße
Matthias

@paulinsche auf eigenen Wunsch aus dem Adminteam entfernt.

Danke für die viele Zeit und das Wissen, was du in das Projekt gesteckt hast und alles was du insbesondere mir beigebracht hast.

  • Domäne Dingden auf die 14 gelegt, Commander und Fanlin sind die Gateways.
  • IPV6-RP-Filter abgeschaltet, weil es den irgendwie doch nicht gibt
  • Ansible für den Kartenserver gefixt, sodass nicht ständig die Karte der Domäne 26 zerstört wird. Symlinks werden jetzt ignoriert (Notiz an @Fungur)

Tunnel zu Dus und Fra auf Parad0x, Ausrufer und Commander deaktiviert.

Dadurch gehen auf Parad0x und Commander alle Verbindungen rüber zu Fanlin und bei Ausrufer gehen sie noch über Berlin.

Denkfehler, weil eingehende Pakete immer über den Standort kommen, wo die Nat-IP anliegt.

Fra wieder aktiviert und nur Dus auf den dreien deaktiviert. Das verhindert Querverkehr.

Ein Fehler in der Ansiblevorlage für Bird hat uns das interne Routing zerschossen. Das hatte ich mal irgendwann falsch gebaut, heute wurde es ausgerollt, das hatte die von @BauerJup gemeldete Störung verursacht.

Ist jetzt repariert.

  • Greyworm abgeschaltet
  • DHCP-Bereiche der Domänen 7-11 umverteilt
  • Routingbug bzgl. FFRL V4 Nat-IP-Bereich gefixt, aber noch nicht ausgerollt

Forum auf remue migriert, altes Forum abgeschaltet.
Danke für die Unterstützung @descilla & @MPW

Das Forenbackup wird jetzt auch wieder täglich auf meinen Rechner gesichert.

192.168er Tunnel-IPs werden jetzt auch wieder geroutet, damit man auch von den Gateways ohne Quell-IP alle IPs im ganzen Netz pingen kann.

Bird auf alle Gateways ausgerollt.

Ich habe die Wikifunktion sämtlicher /FreiFunkMuenster-GitHub-Repositories deaktiviert. Wird eh nicht genutzt und verwirrt nur (descilla ist Zeuge).

Das Gateway Parad0x hat jetzt testweise den Kernel 4.7.

Dabei ist aufgefallen, dass auf Des1 Bind nicht funktioniert hat, mehrfaches Neustarten hat nichts gebracht, daher Server neu gestartet.

Scheint jetzt wieder zu laufen.

=> Wir sollten langsam mit mehr Kernen experimentieren.

Das wäre toll. „Willkommen in 1995“ :slight_smile:

Ich habe gerade auf barristan und ausrufer wieder collectd aktiviert, aber das plugin für dhcp deaktiviert. So sollte der ressourcenverbrauch moderat bleiben, aber man bekommt dennoch ein paar informationen.

Kernelparameter maxcpus=0 auf RHE deaktiviert und VM neu gestartet.