Aliases.json


#1

Hi, welches Interface auf dem Gateway hat die MAC 02:ca:ff:ee:, ? Würde gerne die aliases.json beim Hopglass-Serever einsetzen.

Muss danach auch ein “grunt”-Befehl abgesetzt werden im Client-Ordner ?


#2

Hallo, nein der Server und der Client sind zwei separate Programme. die “02:ca:ff:ee::::” mac addressen sind typischerweise auf den Bridges konfiguriert br{DOM_ID}. Wenn du die Rolle py_respondd auf den Gateways ausrollst, brauchst du gar keine alias.json mehr und hast sogar noch weitere Informationen über die Gateways in der Karte:


#3

Vielen Dank für den Tipp, habe ich ausgerollt und es funktioniert gut.
Eine Frage: ist es erlaubt, die Kontaktadresse zu ändern? Du möchtest bestimmt keine Anfragen bezüglich unserer Gateways bekommen.

Und wenn ja, wo geht das? In den Templates habe ich es nicht gefunden.


#4

Noch eine Frage: ein Gateway wird in der Karte mit seinen Adressen 02:ca:ff:ee:03:04 und 02:ca:ff:ee:04:04 angezeigt. Das Gateway wurde neu aufgesetzt und ausgerollt mit der Rolle py_respondd.

Jetzt wird der Name nicht automatisch aktualisiert. Ich möchte jetzt das Gateway nicht abschalten, um zu warten, bis die Karte es “vergisst”.

Ich habe folgende gefunden: https://freifunk-muensterland.de/wiki/doku.php?id=technik:kartenknoten-entfernen

Würde ich machen, allerdings habe ich auf dem Kartenserver noch nicht gefunden, in welchem Pfad die nodes.json liegt. Kann mir das jemand mitteilen oder gibt es einen besseren Weg, den Namen auf neuen Stand zu bekommen?


#5

Ich werde das mal konfigurierbar machen. Danke für den Hinweis. Melde mich dann noch mal. :wink:

Mhh, normalerweise sollte sich der Name automatisch (nodeinfo Pakete werden aber nur alle 5 Minuten “angeforder”) ändern.

Das ist für die alte Karte. Bei der neuen Karte liegen die node.json Dateien nicht mehr auf der Platte (außer im nginx Cache). Sie werden vom hopglass-server on-request “erstellt”. Dennoch sichert der hopglass server regelmäßig (alle 5 Minuten) seine Daten auf die Platte. Die Datei findest du hier: /etc/hopglass-server/default/raw.json

PS: Den py-respondd dienst hast du schon mal versucht neu zu starten?


#6

Sehr seltsam, der Dienst py-respondd ist wohl während des Rollouts nicht enabled worden. Nach manuellen Start funktioniert es jetzt problemlos.


#7

Ich habe diesen Teil nun in die Config verlagert. Dort kann man nun weitere Informationen angeben, die dann den nodesinfos hinzugefügt werden. Siehe config.json.example


#8

Vielen Dank für deine Mühe!

Ich bekomme es nicht zum Laufen:

  • Dateien /opt/py-respondd/config.json und /opt/py-respondd/respondd/Nodeinfo.py angepasst (das scheinen mir die geänderten Dateien zu sein)
  • systemctl restart py-respondd durchgeführt
  • im Hopglass-Verzeichnis grunt ausgeführt
  • Keine Änderung

Was könnte ich falsch gemacht haben?