Ansible probleme mit der neuen Mapserver.yml


#1

Hallo,

ich habe versucht, die neuen Rollen für die neue Karte auf einer neuen VM auszurollen.
Leider bleibt Ansible mit der folgenden Fehlermeldung hängen.

TASK [mapserver_hopglass-server : install dependencies] ************************
skipping: [karte]

TASK [mapserver_hopglass-server : Create HopGlass-server Config directory if not
existent] ***
ok: [karte]

TASK [mapserver_hopglass-server : Setup systemd service] ***********************
fatal: [karte]: FAILED! => {“changed”: false, “failed”: true, “msg”: “Source /op
t/hopglass/server/hopglass-server@.service not found”}
to retry, use: --limit @/opt/ansible-ffhp/mapserver.retry

PLAY RECAP *********************************************************************
karte : ok=43 changed=1 unreachable=0 failed=1

@descilla
Hast du vielleicht eine Idee, was ich machen könnte?
Was mir aufgefallen ist, die Datei /group_vars/mapserver ist leer.
Fehlen hier vielleicht Variablen?
Viele Grüße
Christoph


#2

Ups, da ist uns wohl das hopglass repo anstatt des hopglass-server repos rein gerutscht.

Ist gefixt:


PS: Wir werden im Übrigen wieder auf das Haupt-Repo schwenken, sobald diese beiden PRs angenommen wurden:


#4

Hi @descilla

Danke für den schnellen Fix.
Allerdings habe ich jetzt ein weiteres Problem.
In der 30-batman.cfg wird die interne Nat-IP von Hetzner verwendet anstatt die externe IP die ich in den Hosts angegeben habe.
Gibt es eine Variable, die ich anpassen kann, um dieses zu verhindern oder sollte ich die per Hand abändern?
VG
Christoph


#5

oh verdammt das war ich…
Da hab ich wohl die repos verauscht… :see_no_evil:


#6

Das hatten wir an vielen Stellen schon angepasst. Lokal muss immer die von eth0 verwendet werden und extern die von außen. Das kann Ansible eigentlich, kann aber sein, dass das da noch nicht drin ist.

Guck dir dazu mal Commit 801a5c81 an, erste Zeile wie es vorher war und untere Zeile, wie man das elegant mit Ansible lösen kann, dass er die interne IP nimmt:

-        pre-up ip link add $IFACE type gretap local {{ansible_ssh_host}} remote {{hostvars[host].ansible_ssh_host}} dev eth0 key {{domaene[0]|int}}
+        pre-up ip link add $IFACE type gretap local {{ansible_default_ipv4.address}} remote {{hostvars[host].ansible_ssh_host}} dev eth0 key {{domaene[0]|int}}

Wenn das da noch falsch drin ist, an einer Stelle, freuen wir uns über einen PR :).


#7

Hi,
dank dem @MPW war es mir möglich, dem Mapserver seine Interfaces nun korrekt einzubinden.
Jetzt habe ich aber ein weiteres Problem mit Nginx.
Er erstellt ein Cert und will den Server dann neu starten.
Dies schlägt aber mit folgendem Fehler fehl:
invalid parameter “http2” in /etc/nginx/sites-enabled/default_ssl:2
Hat hier jemand eine Idee?
Ich bin gerade dabei, in der Nginx-Config den fest eingetragenen Wert “Karte” durch die Variable {{inventory_hostname_short}} zu ersetzen. Ich wollte die Karte unter dem Namen karteneu testen.
Gibt es hier für noch eine bessere Möglichkeit oder gibt es sogar einen Grund, wieso diese Variable nicht hinterlegt ist?
Sorry für meine ganzen Fragen…
Grüße
Christoph


#8

Welche Version von nginx ist denn installiert worden?
http2 geht wohl erst ab Version 1.9.5
Edith: wir verwenden Version 1.10.3

Ne gibt keinen Grund… wir nutzen zum Test meist eine andere Domain von daher war das bei den Tests kein Problem…
Kannst also ruhig ersetzen.

Kein Problem… :slight_smile:

Gruß Marius


Hopglass nginx Fehler
#9

Hi,
Danke für die schnelle Antwort, dann werde ich mal ersetzen.
Er hat die Nginxversion 1.6.2 installiert, dann ist das klar.
Werde mal updaten…
Grüße
Christoph


#10

Das war früher schon mal aufgefallen, dass das mit dem neuen Nginx anders läuft. Dazu gibt es ein paar Issues auf Github.