Client PC am LAN bei Mesh on LAN?


#1

Habe den Unglücklichen Umstand das ich einen WR841N v10 als wichtigsten FF Knoten einsetze der für alle Meshenden Router der einzige Router mit Uplink bei bester Signalstärke darstellt. An diesen Router hab ich die Funkbrücke zum Kirchturm und vom Kirchturm die Funkbrücken zu den Flüchtlingsunterkünften. Um die Flüchtlings PCs mit Ubuntu Updates etc. zu versorgen wollte ich nun auch noch den Ubuntu Mirror Server an die Lanports eben diesen Routers anschließen.

Hab nun festgestellt das wird nix weil der WAN ist für den Uplink blockiert, die LAN Ports sind für das Mesh on LAN aktiviert und nen Client bekommt keine IP mehr zugewiesen wenn Mesh on LAN aktiviert ist :frowning:

Hab jetzt nen weiteren WR841N v9 mit Mesh on LAN auf Mesh on WAN dran gehängt und bei diesem Router das Mesh on LAN ausgeschalten. Ich bin mit diesem Konstrukt aber nen meng unglücklich. Über WLan will ich den Ubuntu Mirror Server nicht dranhängen. Jemand nen Vorschlag wie man das besser verkabelt?


#2

Man muss ein extra vlan anlegen, auf das man dann nur einige Ports mappt. Ich habe selbst schon mal drüber nachgedacht, es aber noch nicht umgesetzt. Ich hoffe dieses wiki hilft dir weiter: https://wiki.freifunk.net/Hamburg/router_Schnittstellen#Mesh_auf_einem_LAN_Port_bei_gleichzeitigem_Client-Netz_auf_den_anderen

Ansonsten hier noch mal die Grundlagen aus dem OpenWRT wiki: https://wiki.openwrt.org/doc/uci/network/switch


#3

Ich hab das mal ausgiebig getestet und folgende Zeilen in der /etc/config/network hinzugefügt:
Auf dem Interen Switch in meinem 1043v2 wird hiermit ein VLAN “41” angelegt.
Alle Ports sind als “tagged” makiert. Sprich, Datenpakete mit dem entsprechenden VLAN-Tag werden geswitcht.

  config switch_vlan
        option device 'switch0'
        option vlan '41'
        option ports '0t 1t 2t 3t 4t'

Datenpaktete ohne VLAN-Tag werden über die vorhandenen Zeilen ins VLAN 1 geswicht:

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

Nun muss das VLAN 41 noch mit irgendeinem Interface/Dienst reden:

config interface 'mesh_lan'
        option macaddr 'c6:6f:20:b9:08:2c'
        option mesh 'bat0'
        option proto 'batadv'
        option auto '1'
        option ifname 'eth1.41'

eth1 hängt am Port 0 des Switches. .41 fügt das entsprechende VLAN-Tag hinzu.

An einem Zweiten Router habe ich jetzt folgende Zeilen angepasst:

config interface 'mesh_wan'
        option ifname 'eth1.41'
        option mesh 'bat0'
        option proto 'batadv'
        option auto '1'

Anstelle von br-wan ist eth1 für die WAN-Schnitstelle eingetragen und .41 um in das passende VLAN zu gelangen. Schließe ich jetzt den WAN von Router 2 an einen LAN von Router 1 an, landet dieser im Mesh-Netz. Um zu verhindern, das er 2. Router unnötig Resourcen benötigt (IP-Adresse etc.) habe ich am 2. Router noch folgende Zeilen beim Interface WAN entfernt:

 option proto 'dhcp'

damit wird keine IP aus dem Client-Netz abgerufen, und es wird nur übers Meshnetz kommuniziert.

Hänge ich jetzt einen “doofen” PC an die LAN-Ports des ersten Switches, landet dieser im Client Netz.
Kommt aber ein Teilnehmer dran, der das VLAN-Tag 41 mitbringt, landet dieser im Mesh-Netz.

Über den Switch lassen sich alle möglichen Kombis einstellen.
Wahrscheinlich nur nicht updatefest.

Infos zum Switching im 1043v2 unter open-wrt gibts unter: https://wiki.openwrt.org/toh/tp-link/tl-wr1043nd#switch_ports_for_vlans


#4

Soweit ich weiß, kann der 841 nicht tagged und untagged auf einem port. PC müssen dann eine gesonderte Konfiguration bekommen, was keine besondere Hürde ist.


Tagged VLAN am TL-WR-841N V10
#5

Der einzige PC der gesondert konfiguriert werden müsste wäre ja nur der Ubuntu Mirror Server. Klingt gut und werde ich mal testen. Danke für die Antworten.