DNS-Auflösung für Knoten

#1

Moin,

ein fast vergessenes Feature: Als ich gerade mal wieder die IPV6 meines Router suchte, fiel mir wieder ein, dass @Fungur da mal was gebaut hatte:

Mit knotenname.knoten.freifunk-muensterland.de erreicht ihr eure Knoten!

Ich glaub das wurde nie irgendwo bekannt gegeben, daher hole ich das hiermit mal nach.

Grüße
Matthias

3 Like
#2

Moin,

könntest Du einen Beispiel Link posten?

Http://Gazelle02.Knoten.freifunk-muensterland.de
Funktioniert für mich nicht…

#3

Du bekommst darüber nur die IPV6. Der Browser kommt damit nicht klar, weil für die Domäne freifunk-muensterland.de HTTPS erzwungen wird und das können die Knoten nicht.

Ich hatte dazu gerade ein Issue eröffnet: https://github.com/FreiFunkMuenster/ansible-ffms/issues/27

$ dig gazelle02.knoten.freifunk-muensterland.de AAAA

; <<>> DiG 9.9.5-3ubuntu0.8-Ubuntu <<>> gazelle02.knoten.freifunk-muensterland.de AAAA
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11275
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1460
;; QUESTION SECTION:
;gazelle02.knoten.freifunk-muensterland.de. IN AAAA

;; ANSWER SECTION:
gazelle02.knoten.freifunk-muensterland.de. 3600    IN AAAA    2a03:2260:115:100:ea94:f6ff:fe29:d998

;; Query time: 51 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Mar 28 00:31:13 CEST 2016
;; MSG SIZE  rcvd: 98
1 Like
#4

Interessierte Nachfrage aus purer Neugier: was müsste denn geändert werden, damit es über httpS funktioniert? Müsste dafür das Freifunk-Muensterland.de Zertifikat auf jedem Router benutzt werden? Oder dürfte der Router sein eigenes Zertifikat mitbringen? Oder geht das überhaupt nicht?

Dies ist kein versteckter Featurerequest :slight_smile: Nur ein Gedankenspiel…

1 Like
#5

Gluon kann aus Platzgründen kein SSL.

Wir müssen eher abschalten, dass er es zwangsweise über https probiert.

Grüße
Matthias

#6

Wir könnten das “includeSubDomains” im HSTS Header mal rausnehmen…

#7

Ich habe es entfernt.

In einem frischen Browser geht es jetzt. Für alle, die es noch im Cache haben, wird es am 28.03.2017(!) funktionieren, weil jemand es für sinnvoll gehalten hat, die Verfallszeit für die Einstellung auf ein ganzes Jahr zu stellen. Die Frist beträgt jetzt 30 Tage.

Der Privatmodus des Firefoxs umgeht die Einstellung übrigens, falls es jemand testen möchte. Das aus dem Cache des Browsers zu löschen, scheint nach fünf Minuten googlen nicht trivial zu sein ohne seinen ganzen Verlauf einzustampfen.

Und damit ist das erste auf Github gelistete Problem gelöst!

2 Like
#8

Ist aber best practice.