FF-Knoten kurzfristig als WLAN-Client nutzen?


#1

Ich habe gerade folgendes Problem:
An einem entfernten Standort habe ich eine Fritzbox, deren DSL-Zugangsdaten nun ungültig sind. Das Gerät hat aber als AP noch ein aktives WLAN, welches bis zu einem Freifunk-Knoten reicht, der wiederum über einen anderen Uplink per Kupfer online ist.

Jetzt die schlaue Frage:
Kann ich den FF-Knoten vorübergehend als WLAN-Client in die FritzBox einbuchen, um dann per SSH-Portforwarding die FritzBox zu konfigurieren?
Das würde mir die Autofahrt dahin ersparen…

Viele Grüße,
Peter


WR841 Traffic Statistic
#2

Der FF-Knoten müsste doch eine IP-Adresse von der Fritzbox haben, da die ja normalerweise als Uplink genutzt wird. Wenn Du nicht gerade in der Fritzbox den FF-Router im Gast-LAN hast, solltest Du als “normaler” Client in der Fritzbox sein.

Ich würde also den FF-Router “normal” einstellen (blau = VPN mesh) und dann die Fritzbox von einem vor Ort per LAN Kabel dran dängeln lassen wenn Sie das nicht schon ist.


#3

Es gibt an den Standort eine zweite Fritte, die ein internes WLAN bereitstellt. Die hat normale Weise keine Verbindung zum FF Knoten.
Diese zweite Fritte ist gerade DSL-mässig offline. Da würde ich mich gerne vom FF Knoten aus einbuchen, um die Konfiguration zu flicken.


#4

Hängen an der sogenannzen zweiten Fritz FF-Router der zufällig per mesh weiter funktioniert?

Sonst könntest du mit Glück ja versuchen die Fritz auf WLAN-Client umzustellen. und dich dann, auf die andere Fritz einwählen und flicken? Die Fritten müssten sich aber dann gegenseitig sehen.

Du hängst dann immernoch an den gleichen FF-Router und kannst darüber über diese neue “WLAN-Krücke” die 1. Fritz flicken. -> die wieder online die 2. Fritz wieder auf alte Einstellung zurück, fertig.

Nur so ne Idee, wenn das aber mit Umstecken usw. verbunden ist, kannst das ja womöglich vergessen.
Daher keine Gewähr, da ich nicht genau weiß, ob man da noch was umstecken muss.


#5

@Peter, ja das geht, ist aber mit 841ern relativ wackelig.

Ich würde das Clientnetz auf jeden Fall erstmal ausschalten, nur Mesch anlassen.

Hier ist eine Anleitung: |45x45

fuzzle

Mai '16

@oscar : ich wollte nochmal auf das script / package von mir hinweisen, das zumindest an den 841ern zu funktionieren scheint (aber gerne gerne testen und mir bescheid geben) denn das mit dem fehlenden iw connect hat mir auch große Probleme gemacht
hier der part meiner lösung :

...
        foomac="something"
        ffssid="someotherthing"
        iw phy0 interface add update type managed
        ifconfig update hw ether $foomac
        ifconfig update up
	# install new if in /etc/config/wireless
	uci set wireless.update_radio0=wifi-iface
	uci set wireless.update_radio0.ifname=update
	uci set wireless.update_radio0.network=update
	uci set wireless.update_radio0.disabled=0
	uci set wireless.update_radio0.device=radio0
	uci set wireless.update_radio0.mode=sta
	uci set wireless.update_radio0.macaddr=$foomac
	uci set wireless.update_radio0.ssid=$ffssid
	uci commit
	# restart wifi and get ip 
	wifi; sleep 2;
        # nachtrag [edit]
        echo 2 >> /proc/sys/net/ipv6/conf/update/accept_ra
	udhcpc -B -b -i update

Fortsetzung der Diskussion von Batman v14 zu v15 upgrade - gluon package: Wie bekomme ich das hin das ein neues Interface auf einem Router selbst sich als Client einloggt (das geht) und dann DNS und v6 Routen bekommt. Irgendwo versteh ich das nicht, v4 ist alles kein Problem … [ edit: v6 ging via echo 2 >> /proc/sys/net/ipv6/conf/update/accept_ra , wie oben schonmal erwähnt ] https://raw.githubusercontent.com/viisauksena/gluon-v14tov15-helper/master/files/lib/gluon/v14tov15-helper/v14tov15-…

https://raw.githubusercontent.com/viisauksena/gluon-v14tov15-helper/master/files/lib/gluon/v14tov15-helper/v14tov15-helper

Das ist für FF, somit ohne Passwort. Ob du für ein WPA2-Netzwerk noch den wpa_supplicant brauchst, weiß ich gerade nicht. Ich fürchte schon, kann sein, dass du den erst nachinstallieren musst. Ob das auf einen 841er noch drauf passt, weiß ich gerade nicht. Auf einem 1043er sollte es problemlos gehen.

Viele Grüße
Matthias


#6

Achso und wenn du dann drin bist, einfach eine Portweiterleitung:

ssh -L 8080:192.168.178.1:80 root@ipv6-des-Knotens

und dann lokal über http://localhost:8080 die FB konfigurieren.

Problematisch ist es, wenn dein Knoten ggfs. auch an einer FritzBox hängt. Dann ggfs. die IP von br-wan wegnehmen oder so.


#7

Danke, ich probier´s aus!


#8

Ich habe es leider nicht geschafft, mich in das verschlüsselte WLAN einzubuchen. Auch nicht wpa_supplicant… Ich habe es hier erstmal aufgegeben, da ich zum betroffenen Standort nun aus anderem Anlass sowieso fahren muss.

Vielen Dank für Eure Tipps!
Es kommt bestimmt noch eine Gelegenheit, bei der ich das brauchen kann… :wink:


#9
$ wpa_passphrase ssidMeinesWLANs passwort123 > ssidMeinesWLANs.conf
$ wpa_supplicant -i interface -c ssidMeinesWLANs.conf