FF-Knoten LAN auf priv. umstellen einzelne Ports


#1

Ich hab vor, wenns ohne großen Aufwand geht auf den 940er Router eine Buchse per privates LAN zu machen. Oder besser gesagt wie kann ich auf den Gluon-Dingern auch noch VLANs reinkloppen bzw. definieren. Ein wenig experimentierfreudig halt. Dann könnte ich nämlich einfach den Entertain da dranhängen und spar mir das lange LAN-Kabel einfach.
Man liest ja öfter, dass man eth0 und eth1 (Mesh-LAN) tauscht sodass man auf dem blauen Port FF bzw. je nach Einstellung dann Mesh hätte.
Hier die Config:

root@Knoten:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb7:xxxx:xxxx::/48'

config interface 'wan6'
        option proto 'dhcpv6'
        option sourcefilter '0'
        option ifname 'br-wan'
        option ip6table '1'
        option peerdns '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

config interface 'wan'
        option ifname 'eth0'
        option auto '1'
        option peerdns '0'
        option type 'bridge'
        option proto 'dhcp'
        option multicast_querier '0'
        option macaddr 'xx:xx:xx:xx:xx:xx'

config rule6 'wan6_lookup'
        option mark '0x01/0x01'
        option lookup '1'

config route6 'wan6_unreachable'
        option type 'unreachable'
        option table '1'
        option target '::/0'
        option metric '65535'
        option gateway '::'
        option interface 'loopback'

config interface 'client'
        option type 'bridge'
        option macaddr 'xx:xx:xx:xx:xx:xx'
        option proto 'dhcpv6'
        option reqprefix 'no'
        option peerdns '1'
        option sourcefilter '0'
        option robustness '3'
        option query_interval '2000'
        option query_response_interval '500'
        list ifname 'bat0'
        list ifname 'eth1'

config interface 'mesh_wan'
        option auto '0'
        option ifname 'br-wan'
        option proto 'gluon_mesh'
        option fixed_mtu '1'

config interface 'mesh_lan'
        option ifname 'eth1'
        option mesh 'bat0'
        option auto '0'
        option igmp_snooping '0'
        option transitive '1'
        option fixed_mtu '1'
        option proto 'gluon_mesh'
        option type 'bridge'
        option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'mesh_vpn'
        option ifname 'mesh-vpn'
        option mtu '1364'
        option fixed_mtu '1'
        option transitive '1'
        option proto 'gluon_mesh'

config interface 'ibss_radio0'
        option proto 'gluon_mesh'

config interface 'bat0'
        option multicast_router '2'
        option ifname 'bat0'
        option macaddr 'xx:xx:xx:xx:xx:xx'
        option learning '1'
        option proto 'none'

config device 'local_node_dev'
        option macaddr 'de:ad:be:ef:08:01'
        option ifname 'br-client'
        option name 'local-node'
        option type 'macvlan'

config interface 'local_node'
        option ifname 'local-node'
        option ipaddr '10.65.0.1'
        option ip6addr '2a03:2260:115:6500::1/128'
        option netmask '255.255.0.0'
        option proto 'static'

config route6 'local_node_route6'
        option target '2a03:2260:115:6500::/64'
        option gateway '::'
        option interface 'client'

root@Knoten:~#`

#2

Auf den gelben Ports steht ja standardmässig das Mesh-Lan an.
Du könntest in der Konfiguration die Belegung der Ports tauschen. Allerdings wird das beim nächsten Update wieder überschrieben. Dann ist Dein Freifunk-Router plötzlich offline.

Ich habe bei einem Router das WAN-Netz auf alle Ports geschaltet. Die Verbindung zum Internet bleibt auf dem blauen. Dan kann ich an den gelben Ports noch Geräte anstecken, die dann im privaten Netz rauskommen. Der Plan ist, das beim nächsten Update diese Einstellungen zwar wieder auf Standard springen, der Freifunk-Router ist dann aber weiter online, weil der Internet-Link weiter am blauen Port hängt. Nur die Endgeräte hängen dann (offline) am gelben Port, der dann halt wieder Mesh macht. Das kann man dann aber problemlos per SSH wieder gerade ziehen.
Bei mir sieht das so aus:

uci set network.wan.ifname='eth0 eth1'
uci set network.mesh_lan.ifname=''
uci commit 
reboot

Die Schnittstellennamen können m.W. bei den verschiedenen Geräte variieren.


#3

ah so also doch über uci ändern. Könnte aber rein theoretisch hingehen und wie schon oben geschrieben hier im uci die eth0 und eth1 tauschen. hätte dann wan und priv. LAN auf gelb und blau wäre dann FF-Netz bzw. Mesh? Oder geht der Plan nich auf?
Da der nicht der einzige Knoten ist und die Kanäle durch nen Update eh alle auf CH1 zurückgestellt werden, würde der danach durch das Update den uplink zwar verlieren aber meshen können und bliebe bis zum umbiegen weiter online.


#4

Klar, tauschen geht natürlich auch…


#5

musste noch andere Angaben die eth0/1 enthielten ändern, damits funktioniert. so hatte der auf einmal 11 Clients angeblich. Nämlich die im privaten Netz und dessen WLAN hingen.
So konnt ich den Switch rausnehmen. Vielleicht kann man ja mal was mit VLAN experimentieren wie das so geht. Komme nächste Woche auf jeden Fall wieder vorbei!


#6

Tauschen gilt sogar als updatefest. Machen viele.


#7

Galt als updatefest. :wink:
Beim letzten Update hats mir genau diese Port-Tausch-Config bei einem 841er zurück gesetzt.


#8

Ärgerlich. Es war immer mal gedacht, die Ports komplett einzeln konfigurierbar zu machen, aber bisher ist das nie jemand angegangen. Cool wäre halt sowas, wenn man z. B. den ersten LAN-Port als Mesh, den zweiten als Clientnetz usw. konfigurieren könnte.

Das Problem oder das was es kompliziert macht, ist leider, dass das auf jedem Router anders realisiert ist.


#9

um das wiederum realisieren zu können müssten im UCI bzw. im configmodus ja
auch mehr Felder eingefügt werden, oder? bzw. Ersatzweise mehr UCI Optionen
für lan1,lan2 usw, wenn man das den Konsolenebene allein überlässt. hierbei
handelt es sich ja eher um Optionen die den Laien weniger treffen.