Firmware Version 2.5.6 testen auf UAP Outdoor+


#1

Falls ich als technisch interessierter Laie irgendetwas sinnvolles testen kann, bitte immer gerne Bescheid sagen und ggf. die Firmware dann auch für Domaine 39 bauen.


Firmwaretagebuch
#2

Klar… einfach flashen und gucken ob dir was Spanisch vor kommt und ob alles noch so Funktioniert wie erwartet…

http://firmware.freifunk-muensterland.org/domaene39/versions/v2.5.6/ :wink:


#3

Ok, habe die Version 2.5.6 aufgespielt auf

  1. 841Nv9 “mesh only”. Sysupgrade von 2.1.0 -> OK, Gerät bootet erfolgreich, ist wieder in der Karte sichtbar, Statusseite korrekt, Einstellungen übernommen, WLAN vorhanden

  2. UAP-Outdoor+ “mesh only”. Sysupgrade von 2.3.0 -> OK, Gerät bootet erfolgreich, ist wieder in der Karte sichtbar, Statusseite korrekt, Einstellungen übernommen, WLAN vorhanden

Keine Probleme wie mit 2.4.0. Dort beschrieben:

Sieht doch gut aus :thumbsup:


#4

Hmm. Ok. Nach ein paar Tagen Betrieb sind Probleme mit dem UAP zu berichten: nach dem o.g. Update auf 2.5.6 gab es zwar eine SSID “Freifunk”, aber darüber keine IP und damit auch keine erfolgreiche Verbindung ins Netz. Außerdem wurde das Gerät in der Karte und auf der Info-Seite seiner Meshpartner meist nicht mit seinem Namen, sondern nur mit einer MAC-Adresse angezeigt.

Nach Update (mit Übernahme der Settings) auf 2.6.0 zeigte sich das selbe Verhalten. Erst ein neues Einspielen von 2.6.0 ohne Übernahme der Settings brachte Besserung.

Nach den anderswo im Forum von mir und anderen berichteten Problemen mit dem UAP+ würde ich folgende Hypothese wagen:

Seit mindestens Version 2.1.0 der Firmware führt ein Update mit Übernahme der Settings beim UAP+ dazu, dass er nicht mehr korrekt funktioniert, sondern in einen Zombie-Modus geht mit eingeschränkter Funktion (s.o.). Ein Update ohne Übernahme der Settings scheint korrekt zu funktionieren.

Frage: kann/sollte man da weiter diagnostizieren oder es einfach akzeptieren, mit dem Workaround “manuelles Update ohne Übernahme der Settings”?

Wäre halt blöd, wenn es bei jedem Autoupdate zu dem Problem kommt und jedes Mal ein Hausbesuch bei den betroffenen Geräten notwendig wird…


Firmware 2.6.0
#5

Moin,

das du keine IP bekommen hast hat nichts mit der Firmware zu tun. IPv4 Adressen werden in unserem Netz ausshließlich von den Gateways verteilt.
In den letzten Tagen haben wir einiges an den Gateways geschraubt und des öfteren sind welche ausgefallen.
Unter anderem hat der DHCP Server auf 1-2 Gateways mal nen halben bis ganzen Tag nicht gelaufen. Dazu kommt das in einigen Domänen zu Spitzenzeiten oder wenn das Partner-Gateway ausfällt die IPv4 Adressen knapp werden. Jedes Gateway hat für jede Domäne nur ca. 1000 IPv4 Adressen sind alle vergeben, bekommst halt keine mehr.

Kurzum. Deine IP Probleme macht nicht die Firmware… :slight_smile:


#6

Ok, verstehe.

Unabhängig davon scheint es mir relativ reproduzierbar, dass ein Update der Firmware auf 2.1.0, 2.4.0, 2.5.6 und evtl. 2.6.0 bei UAP Outdoor+ mit Übernahme der Settings Probleme macht, egal ob über den Autoupdater, über LUCI oder UCI, während ein Update ohne Übernahme bisher stets zu funktionieren scheint.

Die erste Beobachtung dieser Art habe ich vor einem halben Jahr (?) gemacht, als die Autoupdater 2.1.0 eingespielt haben und drei UAP Outdoor+ hier in D39 nicht mehr funktionierten. Die Lösung war damals manuelles Update auf eine Zwischenversion (ohne Übernahme der Settings).

Falls das sonst niemand beobachtet, liegt es vielleicht an einer Besonderheit hier?

Wenn jemand Interesse an der Sache hat, sollte ich es relativ einfach hinbekommen, ein oder mehrere Geräte in den Zombie-Modus zu schicken. Vielleicht kann man ja etwas debuggen oder so…


#7

Sprechen wir hier generell über UAP Outdoor±Gerät oder über deinen komischen, der irgendwie nicht ganz sauber läuft?


#8

Ich hatte über die Zeit Probleme mit vier verschiedenen UAP Outdoor+. Alle Domain 39 und alle nur über WLAN verbunden.

Immer laufen die Geräte hervorragend mit der neu installierten FW und nach einem Update dann gibt es Probleme. Aufgefallen ist es mir das erste Mal, beim Ausrollen von FW 2.1.0. Das könnte wohl das erste Update der Geräte nach Installation gewesen sein.

Die weiteren Probleme habe ich alle mit einem bestimmten Testgerät gesehen. Ich würde aber prophezeien, dass ich das Problem schnell mit einem fabrikneuen UAP Outdoor+ reproduzieren kann.

Ich werde das “zeitnah” ausprobieren…


#9

Habe einen fabrikneuen UAP Outdoor+ mit FF FW 2.1.0 bespielt. Einwandfreie Funktion.

Sysupgrade auf 2.6.0. und wieder verhält es sich komisch.

http://[2a03:2260:115:3900:822a:a8ff:fea0:8460]/

Edit(
Da der Link anscheinend nicht immer funktioniert, hier der Link zu einem Kollegen in der selben Wolke:
http://[2a03:2260:115:3900:822a:a8ff:fe68:4f1d]/
Das Problemkind heißt FreifunkOstbevernTest2 und sollte zumindest auf der Statusseite des Kollegen auftauchen
)

Die Statusseite wird nur “halb” angezeigt. D.h. die Statistiken zu den Verbindungen fehlen. Das Gerät gibt die SSID “Freifunk” aus, aber darüber bekommt mein Android Gerät keine Verbindung: “warten auf IP-Konfiguration”.

Ich würde wetten, dass es wieder einwandfrei funktionieren wird, wenn ich die 2.6.0 erneut einspiele ohne Übernahme der Settings.


Zu aktualisierende Knoten ohne Kontaktdaten
#10

Dann sollten wir dazu mal einen Bug im Gluon aufmachen. Könntest du das übernehmen? https://github.com/freifunk-gluon/gluon/issues

Kann ruhig auf Deutsch sein, da sprechen eigentlich alle der Entwickler deutsch.


#11

Lass das nicht Neoraider lesen :stuck_out_tongue: Englisch wird stark favorisiert, zur Not geht aber auch Deutsch.


#12

Hab’s hier eingetragen:

Ich hoffe, die Referenzen zu Freifunk-Funktionalität sind im Gluon-Bereich verständlich…


#13

Ok, die Kollegen von Gluon glauben, dass es sich um einen Bug handelt, der in v2017.1 gefixt ist, aber nicht im v2016.2 Branch gefixt werden wird.

Wie ist denn eigentlich die Planung mit der FF Firmware? Ist da auch schon geplant, mal auf v2017.1 zu gehen?


#14

Wir sind gerade dabei 2016.2.6 auszurollen.

Für die Outdoor+ könnte man dann von 2016.2.5 direkt auf 2017.1 springen?


#15

2017.1 hat noch ein paar Bugs, die das Ausrollen derzeit nicht sinnvoll machen. Daran wird aber gearbeitet.


#16

Wie ist da eigentlich der aktuelle Stand? Können wir da jetzt die Beta Knoten dazu nehmen?


#17

Gehe ich heute Abend Mal an…