Fragen über Firmware-Versionssprung zu LEDE


#1

Hallo Leute,

wir bei https://www.freifunk-donau-ries.de/ machen jetzt hoffentlich einen Versionssprung von Gluon v2016.2.6 nach v2017.1.5 .

Änderungen wie andere Pakete / Module und Repos haben wir bei euch abgekupfert.

Was habt ihr gedreht um weiterhin wr841-Modelle zu unterstützen; für die fliegt bei uns noch kein Image raus?

Weiter wirft ein getesteter wr842 mit übernommener Konfiguration bei verlassen des config-Mode durch Sichern einen Fehler:

code:
/usr/lib/lua/gluon/web/template.lua:27: Failed to execute template ‘model/wrapper’.
A runtime error occured: /usr/lib/lua/gluon/web/template.lua:27: Failed to execute template ‘gluon/config-mode/reboot’.
A runtime error occured: /usr/lib/lua/gluon/web/template.lua:39: bad argument #1 to ‘parse_string’ (string expected, got nil)
code/:

Grüße, Martin


#2

Hallo Martin,

du musst das Target ar71xx-tiny bauen.

Viele Grüße
Matthias


#3

Hallo Matthias,

Danke für den Tip.

Due to further size increase of the kernel between 3.18 and 4.4, we werenot able to keep support for devices with 4MB flash in the ar71xx-generictarget. For this reason, we’ve introduced the slimmed-down ar71xx-tinytarget, which does not contain opkg, so no installation of new packagesis possible without rebuilding the image. This is probably not asignificant degradation, as the overlay was already too small for usefulpackage installations on these devices before.

Ich hab das betimmt im Januar schon gelesen - und vergesssen …

Grüße, Martin