Freifunk Gronau: Knoten in Domäne 75 FFMSL umziehen

Hi,
in Gronau sind alle Router offline, die die alte Firmware installiert haben. Ich war am Samstag noch in einer Gastwirtschaft zum Geburtstag eingeladen. Habe da direkt Kontakt mit dem Chef aufgenommen. Die bekommen am Dienstag von mir die Münsterland Firmware. Aufgrund das nun alles Offline ist habe ich bei Facebook einen Beitrag geschrieben. Siehe Freifunk Gronau. Ich habe auch zeitgleich Kontakt mit Simon Cleve aufgenommen und der will voll mit einsteigen. Ich denke ich bekomme das gesamte alte Team wieder zusammen. Ich hoffe es geht so weiter, dann sollte es kein Problem sein, die Freifunkrouter zu aktualisieren.
Ich hoffe es war OK, dass ich die Firmware schon auf der Facebook Seite veröffentlicht habe. Ich wollte nur, dass die Leute in Gronau sehen, dass an der Umstellung gearbeitet wird.
Grüße Mike Verstege

Okay, sag wenn wir dich aus der Ferne unterstützen können.

Kann ich deinen letzten Beitrag in ein öffentliches Thema umwandeln? Dann bekommen es auch alle hier im Forum mit.

Hi, ja kein Problem. Simon hat mir berichtet das einige seiner Router zu Hause noch gehen. Es sind doch noch einige online. Aber überwiegend sind die Geräte offline.

Die Gasttätte Concordia ist wieder online. Concordia

4 Like

Die nächsten 2 Router vom Sport Gym Gronau sind auf dem aktuellen Stand und wieder online.Sportgym

4 Like

Aktuelle probleme bei Concordia Punkte 02 03 04 05 offline und zu Punkt 01 kann keine Verbindung aufgebaut werden. Auch nicht bei vorkonfigurierter DNS? Sofern Software vorhanden kann ich einen Node bilden. Kriege 01+04+05. Gruß Nixan

Derzeit funktionieren die Geräte wieder. Die Geräte müssen vom Betreiber gelegentlich neugestartet werden, wenn so ein Problem vorliegt. Hierzu reicht es das Stromkabel einen kurzen Moment vom Strom zu trennen. Gerne kann sich der Betreiber auch telefonisch bei mir melden um eine Termin zur Überprüfung abzustimmen.

Wir arbeiten gerade daran viele Geräte auszutauschen.

Wir werden auch in Zukunft in Gronau ein monatliches Treffen veranstalten, wo jeder kommen kann um Fragen zu stellen oder Geräte zu flashen.

Ich bin nahezu jeden Abend ab 18:00 Uhr telefonisch unter 02562/9491356 erreichbar.

1 Like

Moin,

habt ihr die Geräte schon auf 4.1.0 aktualisiert? Da sollten die Verbindungsabbrüche nicht mehr passieren.

@Mike, dürfen wir auch mal dazu kommen :grinning:?

Grüße
Matthias

Ja die geräte sind schon auf der Firmware 4.1.0. Alle neuen Geräte die ich einrichte installiere ich ein Cronjob der alle 5 min prüft ob ein Ping gesendet werden kann und empfangen wird. Sollte das nicht funktionieren wird nach 30 Sekunden dieser Test nochmal durchgeführt. Sollte wieder keine Antwort kommen rebootet sich das Gerät. Das Problem tritt bei allen Geräten auf die mehr als 3 Nodes per WLAN sehen und sich verbinden. Warum es passiert kann ich nicht sagen aber dieser Workaround hilft. Eventuell könnt Ihr das in der Firmware implementieren, sodass ich nicht bei jedem neuen Gerät diesen Cronjob einrichten muss. das wäre eine gute Verbesserung.

Ja du darfs auch zu diesem Treffen kommen. Es wird natürlich niemand ausgeschlossen. Ein Termin steht allerdings noch nicht fest. Sobald ich das mit den Simon und Stephan abgeklärt habe, gebe ich den ersten Termin hier und auf der Facebook Seite frei.

Hm, das ist aber ein fieser Workaround. Dass die Geräte sich so oft weghängen, sollte eigentlich nicht passieren.

Zumal das in anderen Domänen nicht der Fall ist.

Deine Cronjobs werden vom nächsten Sysupgrade vermutlich deaktiviert werden.

Ja das vermute ich auch. Deswegen habe ich gefragt ob man den cronjob im Image mit aufnehmen kann. Die meisten Geräte die hier im Umlauf sind, sind 841er. Die haben das Problem auf jedenfall. Die paar größeren Geräte haben dieses Problem bislang noch nicht gehabt. Ich weiß nicht ob es Zufall ist oder wirklich an der Hardware liegt. Ich komme auf jeden Fall mit dem Problem in Münster vorbei. Dann können wir das nochmal besprechen.

Geräte hängen sich nicht auf. Nur das WLAN der Geräte. Die Lampe am Router die sonst blinkt bleibt dauerhaft leuchten. LAN funktioniert dann noch. Man kommt auch per SSH auf das Gerät. Ich selber habe einen bei mir draussen der auch dieses Problem zwischendurch hat.

Ich meine es gibt oder gab zumindest sogar mal ein Paket, was das gemacht hat.

@Mike Könntest du den Log bei einem „abgestürzten“ hier veröffentlichen?

logread

Hier die Logdatei

logread.txt (63,0 KB)

Mh… daraus werde ich leider nicht schlauer… das offline-ssid script erkennt das die tq zu einem Gateway 0 ist und ändert die SSID auf eine offline.

Magst du die Ausgabe von

batctl o

senden?

Sorry das Gerät ist wieder neugestart. Wir müssen warten bis es das nächste Mal passiert. Sobald das passiert ist das WLAN nicht mehr vorhanden. Man sieht auch kein offline WLAN.

Heute ist wieder ein Ausfall des WLAN. Anbei die LOG Datei.batctl.o.txt (21,3 KB)

Der Router ist noch online. Sowohl die Kabel- als auch die WLAN-Meschverbindungen stehen, wie man im Log sieht.

Hatte ich so noch nicht. Evtl. könnte es helfen, sie einmal auf Originalfirmware zurück zu bringen. Oder wenn es 841er sind, sie ggfs. zu tauschen.