[gelöst] Benötige Unterstützung

Hallo zusammen und ein frohes Neues Jahr!

Ich habe eure Ansible-Konfiguration nach Anpassung an unsere Begebenheiten auf ein paar neuen VMs ausgerollt. Obwohl augenscheinlich die FFRL-Tunnel stehen und der Client auch eine IP bekommt, funktioniert der Internetzugang nicht.

Wer könnte mir helfen?

Wie registriere ich mich für euren HipChat?

Moin @collimas

Ohne einen Traceroute oder ein paar mehr Infos wird das Schwer zu diagnostizieren. Laufen denn alle Dienste?

  • Bird
  • Bird6
  • Bind

Welches Betriebssystem setzt du ein?

Hier: https://wiki.freifunk-muensterland.de/signup.action einen Account für unser Wiki anlegen und sich dann mit diesen Anmeldedaten beim Hipchat unter https://hc.infrastruktur.ms/ anmelden.
(Achtung beim HipChat kann man sich nur mit der E-Mail Adresse und nicht mittels Benutzername anmelden.)

1 Like

Moin @corny456,

ob wirklich alle benötigten Dienste laufen, habe ich noch nicht überprüft. Gibt es eine Liste aller Dienste, die auf einem Gateway laufen müssen?

root@thusnelda ~ # systemctl status bird
● bird.service - BIRD Internet Routing Daemon (IPv4)
Loaded: loaded (/lib/systemd/system/bird.service; disabled; vendor preset: en
Active: inactive (dead)
root@thusnelda ~ # systemctl status bird6
● bird6.service - BIRD Internet Routing Daemon (IPv6)
Loaded: loaded (/lib/systemd/system/bird6.service; disabled; vendor preset: e
Active: inactive (dead)
root@thusnelda ~ # systemctl status bind9
● bind9.service - BIND Domain Name Server
Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: en
Drop-In: /run/systemd/generator/bind9.service.d
└─50-insserv.conf-$named.conf
Active: active (running) since Tue 2018-01-02 17:20:44 CET; 16h ago
Docs: man:named(8)
Main PID: 4199 (named)
CGroup: /system.slice/bind9.service
└─4199 /usr/sbin/named -f -u bind

Mmh. Inactive (dead) hört sich bei bird und bird6 nicht sehr gesund an.

Ich habe einen Server bei Hetzner gemietet, OS ist Ubuntu Server 16.04.3 LTS mit einem 4.10er Kernel. Leider bietet Hetzner bei den kleinen VMs kein Debian 8 mehr an und ich wollte keine Experimente mit Debian 9 veranstalten.

Danke für den Link zur Registrierung.

ne die Wichtigsten hab ich aber schon genannt :slight_smile:

Da ist das Problem. Unser ansible läuft noch nicht zu 100% auf Ubuntu. Ausserdem hat der Tunneldigger einen Bug der dazu führt das er mit zu neuen Kerneln nicht mehr läuft.

Das du keine Verbindung ins Inet bekommst liegt daran das Bird (Routing Deamon) nicht läuft.
Unter Ubuntu wird bird noch nicht vom Ansible zum Autostart aktiviert.
Das erledigst du mittels:

systemctl enable bird.service
systemctl enable bird6.service

Das tunneldigger Problem ist das nur noch ein einziger Tunnel zustande kommen kann.
Siehe https://forum.freifunk.net/t/l2tp-tunneldigger-serverdoku-thread/11621/98?u=corny456

Ok, das erklärt vieles. Gibt es eine Empfehlung hinsichtlich des Betriebssystems?

Würde Debian 9.3 laufen?

Leider nein, der Kernel ist auch zu neu.

Wir nutzen immer noch Debian 8 mit maximal 4.9-bpo3, selbst bpo4 geht nicht mehr.

Details dazu siehe in dieser Diskussion.

Viele Grüße
Matthias

Hi Matthias,

mit der Hilfe von corny456 konnte ich das Problem soweit lösen. Mit Debian 8 und dem BPO 2 läuft es soweit, leider ist der BPO 3 nicht mehr verfügbar.

Ich habe noch Probleme mit IPv6, d.h. Clients haben zwar v4 Zugriff, aber nicht über v6 (auf das Internet).

root@thusnelda ~ # systemctl status bird6
● bird6.service - BIRD Internet Routing Daemon (IPv6)
Loaded: loaded (/lib/systemd/system/bird6.service; enabled)
Active: active (running) since Wed 2018-01-03 18:35:09 CET; 31min ago
Process: 4398 ExecStartPre=/usr/sbin/bird6 -p (code=exited, status=0/SUCCESS)
Process: 4392 ExecStartPre=/usr/lib/bird/prepare-environment (code=exited, status=0/SUCCESS)
Main PID: 4403 (bird6)
CGroup: /system.slice/bird6.service
└─4403 /usr/sbin/bird6 -f -u bird -g bird

Jan 03 19:05:39 thusnelda bird6[4403]: ospf1: Bad packet from fe80::5efe:ac…0)
Jan 03 19:05:44 thusnelda bird6[4403]: ospf1: Bad packet from fe80::5efe:ac…0)
Jan 03 19:05:49 thusnelda bird6[4403]: ospf1: Bad packet from fe80::5efe:ac…0)
Jan 03 19:05:54 thusnelda bird6[4403]: ospf1: Bad packet from fe80::5efe:ac…0)
Jan 03 19:05:59 thusnelda bird6[4403]: ospf1: Bad packet from fe80::5efe:ac…0)
Jan 03 19:06:04 thusnelda bird6[4403]: ospf1: Bad packet from fe80::5efe:ac…0)
Jan 03 19:06:09 thusnelda bird6[4403]: ospf1: Bad packet from fe80::5efe:ac…0)
Jan 03 19:06:14 thusnelda bird6[4403]: ospf1: Bad packet from fe80::5efe:ac…0)
Jan 03 19:06:19 thusnelda bird6[4403]: ospf1: Bad packet from fe80::5efe:ac…0)
Jan 03 19:06:24 thusnelda bird6[4403]: ospf1: Bad packet from fe80::5efe:ac…0)
Hint: Some lines were ellipsized, use -l to show in full.

Hast du dazu eine Idee?

Hi,

zeig mal bitte die Ausgaben von

 birdc6 show proto

und

birdc show route export ffrl_ber1 table ffnet.

(beispielsweise, ggfs. ffrl_ber1 durch den eigenen Namen ersetzen)

Falls bei einem Protokoll nicht „Established“ steht, zeig bitte das Interface dazu:

ip a s <kaputtes Netzwerkinterface>

und dann noch gucken, ob du durch den Tunnel pingen kannst, wenn du die Quell-IP manuell setzt:

ping6 -I <lokale IP> <remote IP>

Und für alle Fälle noch die bird6.conf dabei.

Grüße
Matthias

Hi Matthias, danke für deine Unterstützung!

root@thusnelda ~ # birdc6 show proto
BIRD 1.6.3 ready.
name proto table state since info
kernel1 Kernel ffnet up 2018-01-03
radv1 RAdv master up 2018-01-03
bfd1 BFD ffnet up 2018-01-03
device1 Device master up 2018-01-03
ospf1 OSPF ffnet up 2018-01-03 Alone
static_domaene03 Static ffnet up 2018-01-03
static_domaene04 Static ffnet up 2018-01-03
kernel_master Kernel master up 2018-01-03
static1 Static master up 2018-01-03
direct1 Direct ffnet up 2018-01-03
ibgp_hermann BGP ffnet start 2018-01-03 Connect
ibgp_arminius BGP ffnet up 2018-01-03 Established
ibgp_varus BGP ffnet start 2018-01-03 Connect
ffrl_dus1 BGP ffnet up 2018-01-03 Established
ffrl_dus2 BGP ffnet up 2018-01-03 Established
ffrl_fra1 BGP ffnet up 2018-01-03 Established
ffrl_fra2 BGP ffnet up 2018-01-03 Established
ffrl_ber1 BGP ffnet up 2018-01-03 Established
ffrl_ber2 BGP ffnet up 2018-01-03 Established

Die Gateways hermann und varus gibt es noch nicht, deshalb können die Verbindungen nicht aufgebaut werden.

root@thusnelda ~ # birdc show route export ffrl_ber1 table ffnet
BIRD 1.6.3 ready.
185.66.194.55/32 dev lo [direct1 2018-01-03] * (240)

bird6.conf

Hinsichtlich des Pings durch den Tunnel stehe ich auf dem Schlauch - aus welchen Bereichen bzw. von welchen Interfaces sollen lokale und remote IP stammen?

Das GW hat die IP 94.130.26.159. Dein Pubkey ist hinterlegt.

Sieht soweit gut aus, aber es hängt irgendwie am Hop davor:

mpw@Server0:~$ traceroute -n 2a03:2260:2004:400::5
traceroute to 2a03:2260:2004:400::5 (2a03:2260:2004:400::5), 30 hops max, 80 byte packets
 1  2002:b206:2c86:0:3631:c4ff:fe15:4bb6  0.935 ms  1.351 ms  1.596 ms
 2  2002:9164:bc1d::1  43.358 ms  46.580 ms  46.546 ms
 3  2001:610:188:140:145:100:188:1  50.712 ms  51.175 ms  55.516 ms
 4  2001:610:f01:9168::169  66.510 ms  66.528 ms  66.686 ms
 5  * 2a03:2260::3  75.493 ms *
 6  2a01:4f8:c17:28f7::2  84.548 ms  88.764 ms  85.628 ms
 7  2a01:4f8:c17:28f7::2  3148.346 ms !H  3106.474 ms !H  3108.664 ms !H

Gerade keine Zeit, muss ich mir morgen nochmal ansehen.

Ich liebe es, wenn mein Gehirn Probleme löst, ohne dass ich nicht drüber nachdenke. Mir kam da gerade so eine Idee. Dein Problem ist folgendes:

Du exportierst das 2a03:2260:2004:300::/56 sowohl vom gw03 (2a01:4f8:c17:28f7::2), als auch von deinem neuen. Beides korrekt. Aber den beiden fehlt die Verbindung.

Ping man die ::5 (thusnelda), die Route zeigt aber auf gw03, klappt das nicht. Die ::4 (gw03) ist aber pingbar. Würdest du an gw03 bird6 ausschalten, würde Thusnelda auf seiner V6 ::5 sofort pingbar werden.

Entweder mit neuen Präfixen arbeiten oder die Kisten per ibgp oder ospf verbinden.

Grüße
Matthias

2 Like

Super - das war es! Ich habe das Präfix geändert und schon funktioniert alles.

Mitunter ist es doch gut, wenn sich jemand das Setup von außen ansieht.

Dankeschön!

2 Like

Freut mich, dass es klappt.