[gelöst] SSH und ipv6

so, ich hab jetzt zwei 841er am laufen wo ich mich halt öfter mal rumtreibe:
im Montmartre und Mittwochs im Mauerwerk (open Stage: kommen!).

Eigentlich möchte ich mehr über ipv6 lernen und bin dort in der Regel per ssh drauf.
Nun komme ich aber nur rein, wenn ich selbst gerade im FF Netz bin.
Leider habe ich bei mir zu Hause noch einen alten ISDN T-Online Anschluss, also kein ipv6 :frowning:
Also hab ich mir also hier zu Hause ebenfalls einen Router installiert.

Hab zwar festgestellt, dass ich per SSH vom internen Netz über die lokale ipv4 Adresse auf meinen Router komme, aber der dortige dropbear will nicht über ipv6 mit meinen anderen Routern reden. Kann der nur ipv4?

Hab vor einiger Zeit ein altes Macbook geerbt, mit dem komme ich per WLan ins FF-Netz um mit meinen Routern spielen zu können. Jetzt kam die Idee auf, per Kabel ins FF-Netz zu gehen, also mesh on LAN und WLAN ausgeschaltet. Leider bekomme ich keine Verbindung über den LAN Port. Muss ich noch etwas einschalten, damit ein Client am LAN eine Adresse bekommt, so wie im WLAN auch (?dhcpv6 oder sowas).

Gruß, Ditz.

Du musst mesh on LAN ausschalten, dies darf in diesem Sinne nicht aktiv sein. sonst geht der LAN port nicht mit dhcp und normale Clients. Da könntest du sonst nur andere FF-Router anschließen, die dann statt per WLAN mit LAN meshen.

Mesh on WAN dürfte aber grundsätzlich bei einzelnen Routern nicht aktiv sein, da ja über den blauen Port mesh vpn ans Internet stattfindet, sofern der nicht an andere Router mesht.

… mesh on LAN ausschalten

ja genau, hab ich gemacht, aber falsch beschrieben (ändere ich gleich).

Ich schau mal gerade nach:
network.mesh_wan.auto='0’
network.mesh_lan.auto='0’
also hab ich wohl auf beiden mesh ausgeschaltet.

ich habe auch noch die Ports getauscht, so dass Uplink/vpn jetzt über die gelben Ports läuft
und der blaue Port ist dann bei mir der auf dem ich FF über LAN erwarte.

Aber auch wenn ich die wieder zurück tausche bekomme ich keine Adresse :frowning:

Warum gehen denn auf WLAN Clients und mesh parallel und auf LAN nur end oder weder?

Bei Wifi wird dieses Adhoc Netzwerk,welches für Mesh zuständig ist, parallel aufgemacht. Der kann auch noch ein privates WLAN aufmachen. (nur wenn eigener Uplink vorhanden) Die Porteinstellungen hatte ich bei mir noch nicht per uci angetastet. Das hatte ich bei der Ersteinrichtung gemacht. Vielleicht fehlt da ein Eintrag der geändert werden muss. Kann ja heut Nachmittag mal in meine 841er gucken als Vergleich wegen der Mesh Option

nun, mesh auf dem LAN brauche ich jetzt nicht, da ich nur einen Router im lokalen Netz habe. Aber man redet schnell aneinander vorbei: Es gib ja mesh on WLAN, mesh on LAN und mesh on WAN.

Laut https://wiki.freifunk.net/Konsole#Meshing_on_LAN ist das mesh on LAN normalerweise aus und man könne dort weitere Clients anschliessen (was ich will).

Demgegenüber besagt https://wiki.freifunk-muensterland.de/pages/viewpage.action?pageId=7178311 dass genau das ausgeschaltet sei (bzw. MOL ein), da es für den 0815 Nutzer die Gefahr besteht, dass das er FF client Netz und sein lokale Netz verbindet (aber doch nur wenn er eine Verbindung zwischen beiden herstellt, oder?).

so, hab gerade noch etwas gefunden: für network.client.ifname ist bei mir nur "bat0" eingetragen. Muss da noch eth0 (oder eth1 falls getauscht) hinzu?

Dieter.

Standardmäßig ist in der aktuellen Firmeware mesh on LAN an. Clients kann man also nicht anschließen, sondern nur mesh-Router.
Das haben wir gemacht, weil ab und an schon mal Drucker, NAS Gehäuse etc. ungeschützt im FF-Netz landeten. (der Stecker pass ja. :wink: )

… genau das wars: network.client.ifname='bat0 eth1'
eth1 ist mein WAN-Port, weil ich eth1 und eth0 getauscht habe.

Bleibt die ursprüngliche Frage: Natürlich kann auch dropbear ipv6.
Ich Depp hatte die link-local Adressen versucht, so langsam komme ich dahinter :slight_smile:

Ditz.

1 Like

Hallo Ditz,

das Thema scheint mir etwas abgedriftet zu sein. Du willst doch eigentlich nicht per Kabel am Router hängen, sondern auch vor Ort entspannt vom Laptop per WLAN Einstellungen vornehmen können, oder? Es kommt hier auf IPV6 an, das Übertragungsmedium, ob WLAN oder LAN, ist dabei völlig egal.

Ob jetzt WLAN oder LAN ist egal, eigentlich geht es hier doch darum, dass dein Laptop scheinbar kein IPV6 kann.

Die Freifunkrouter nehmen SSH-Verbindungen sowohl per V6 als auch per V4 an, sofern du deinen Schlüssel hinterlegt hast oder ein Passwort gesetzt hast. Ich empfehle immer ersteres, weil das Gerät weltweit über seine IPV6 erreichbar ist und somit ein schwaches Passwort schnell dafür sorgt, dass das Gerät von einem Botnetz akquiriert wird.

Zurück zum Thema: Von Mac hab ich überhaupt keine Ahnung. Jedes aktuelle Betriebssystem kann aber meines Wissens nach automatisch IPV6.

Windows ist glaube ich:

ipconfig /all

Linux:

ip a s

MacOSX laut Google:

ifconfig

Zeig mal die Ausgabe. Dann sieht man sofort, ob am Client (also deinem Laptop) eventuell IPV6 deaktiviert hast.

Schritt 1: Baue eine IPV6-SSH-Verbindung aus dem Freifunknetz auf

Ggfs. auch mal einen Ping auf die V6 machen.

Schritt 2: IPV6-Broker in der FritzBox aktivieren, dann hast du auch an jedem gammeligen alten DSL-Anschluss behelfsmäßig IPV6. Letzteres hab ich auch nur, weil die in der Vodafone-DSL-Abteilung auch zu dumm für V6 sind. Das kann eigentlich jeder aktueller Router (TP-Link und AVM sind mir zumindest bekannt).

Ansonsten komm auch gerne mal mittwochs ab 19:30 Uhr bei einem unserer Treffen in der Warpzone vorbei, dann zeigt es dir bestimmt gerne jemand.

Viele Grüße
Matthias

Hallo Matthias,

sorry für die Konfusion und danke für die Hinweise. Mein Problem ist ja jetzt gelöst.
Ja, ich wollte tatsächlich per Kabel am Router hängen, und tut jetzt auch.
Meine Clients (Mac/Ubuntu/Raspi) machen alle problemlos V6.

Dass ich meiner Fritzbox v6 beibringen kann hatte ich mir schon irgendwie gedacht. Aber das ist wieder ein ganz anderes Thema…

Bist Mittwoch vielleicht mal.

Dieter.

Alles klar, super.

Wie man Kabelvermaschung korrekt per SSH umstellt, steht übrigens hier: https://gluon.readthedocs.io/en/v2016.2.5/features/wired-mesh.html#mesh-on-lan

Nur den UCI-Eintrag zu setzen, reicht zwar für WAN-Masch (blauer Port), nicht aber für LAN.

Grüße
Matthias