Heimnetz-WLAN Roaming


#1

Huhu zusammen,
vorweg noch frohe Ostern :slight_smile:
habe zuhause 3x das gleiche WLAN-Netz. (SSID)

Ziel ist es die Abdeckung so zu gestalten, dass die Geräte automatisch hoppen.
Die Grundvoraussetzung (gleiche IP-Bereiche ohne zusätztliches NAT) sind gegeben und es gibt nur einen DHCP im Heimnetz.

Bei 2en WLANs funktioniert das auch. Gehe zum einen oder zum anderen, vielleicht verliere ich ein Ping, das wars auch.
Obwohl die beide in unterschiedlichen Kanälen arbeiten.
Das einzige was mir “gleich” auffällt ist die Kanalbandbreite. 22MHz respektive 20MHz. Der Übertragungsstandard "802.11 b+n+g"ist bei der Fritzbox auch eingestellt. Im TP-Link Router ist von 802.11 bgn “gemischt” die Rede. Ich gehe davon aus dass hier keine Unterschiede sein dürften sondern nur ne Menü-Darstellungssache ist.
Bei der 7270 bleiben die Clients immer dran “kleben”, der sendet jetzt auch auf 22 respektive 20 MHz. (für 300 Mbit/s optimierte Kanäle rausgenommen) Das ist war die Option für 40 MHz Bandbreite.

Trotzdem bleiben die Clients bis zum Reconnect daran hängen.
Erreichen diese eines der anderen 2 WLANs, hoppen die hin und her bzw. kleben an den 2en und wechseln nicht ohne weiteres zu der Fritzbox.

Hat jemand noch ne Idee was das sein könnte?


#2

Hallo,

das Problem ist eben, dass es kein WLAN-Roaming gibt. Die Geräte bleiben kleben, bis die Verbindung abreißt.

Man kann entweder die Clients aktiv so einstellen, dass sie „agressiv“ roamen, Android kann das zum Beispiel, der wpa_supplicant auch, oder man nutzt professionelle Controller, die die Geräte rüberschubsen, wenn ein anderer Controller eine bessere Signalstärke hat.

Dass eine FritzBox das kann, wage ich zu bezweifeln. Wenn überhaupt in Zusammenspiel mit den Repeatern von AVM, sicherlich nicht zusammen mit TP-Link.

Ich würde mich drauf konzentrieren, den Client auf Roaming zu trimmen.

Grüße
Matthias


#3

“Klebenbleiben” ist das normale Verhalten von Clients.
Clients fangen erst wirklich an nach anderen Netzen zu suchen wenn das Netz (Beacon) das sie hören zu schwach wird.

Lösungen:

  • Eine Variante mit Controller verwenden die die Clients aktiv hin und herschubst. Vermutlich für dich nicht praktikabel.
  • Die Sendeleistung und/oder minimale Geschwindigkeit der AP runter bzw hochsetzen, so das die Verbindung zum Client früher “abreisst”.
    D.h. an der Fritz mal die Leistung runtersetzen.

Leider sind das aber alles Krücken wie alles im Wifi Roaming. In deinem Fall wird das nie so ganz fluffig werden, da die Software die du verwendest die paar Mechanismen die es für Roamingunterstützung auf AP-Seite gibt nicht implementieren.

Ich habe bei mir zuhause übrigens lange am Roaming rumgebastelt, mit TP-Link und Asus Hardware auf OpenWRT. Roaming war immer Mist.
Letztendlich habe ich alles auf (2) Unifys (AC Pro) umgestellt, davon einen an wirklich zentraler Stelle unter Decke - jetzt fluppt es. Kein Roaming ist gutes Roaming :wink:

In einem Bauernhaus mit 0.5m dicken Wänden habe ich 4 Unify AP AC Lite reimgeschraubt wo das Roaming praktisch nun auch gut funktioniert.
(Im Cloud-Key Controller “Advanced” “on” und alles unter 24Mbit abgestellt)


#4

Rüberschubsen fällt weg. Aber wo ändere ich das aggressivere Switchen?

Entwickleroptionen -> Netzwerke “WLAN-Roaming-Scans” erlauben?
Oder meinst du die Funktion zwischen Mobile Netze umswitchen? Das widerspricht ja eigentlich das WLAN zu nutzen.

Gut da habe ich nun die 40 MHz Bandbreite wieder reingenommen. Die kann ja dann ruhig bleiben und die Leistung zu reduzieren ist auch nur “Krücke” wie Ingomar schon schrieb, da die trotzdem erstmal dran hängen bleiben, wenn an den gewünschten Punkten nicht so viel ankommt, aber andersrum andere Ecken dann wieder schlechter versorgt werden.


#5

Die TP-Link AP die mit Freifunk (OpenWRT) auch das private ausstrahlen und der TP-Link VR900v, die Clients die den jeweiligen am stärksten hören, werden von dem genutzt.
Dabei kann der Client mit den TP-Links verbunden sein und auch noch direkt vor der FritzBox stehen. Den nimmt er erst bei Wifi an/aus oder er hört die anderen “gar nicht” mehr.
Ein Test mit dem FF-Router hat das bestätigt

root@:~# uci set wireless.wan_radio0.disabled='1’
root@:~# wifi

Client hoppt zum TP-Link VDSL Router
root@:~# uci set wireless.wan_radio0.disabled='0’
root@:~# wifi

Client switcht auf den FF-Router mit Private Wifi zurück

erkennbar auch an der sich daraus ändernden MAC.
Die Fritzbox bleibt ungeachtet ihres starken Pegels vom Client zunächst ignoriert.

Fazit wäre: unter den 2 FF-Routern und dem TP-Link VDSL Router klappts so ziemlich gut. der 3. FF-Router sendet kein privates WLAN und steht direkt neben dem VDSL.

Der Klebeeffekt ist auf der Fritzbox eher besessen, obwohl die FF-Router auch kein originales TP-Link mehr sind sondern OpenWRT…


#6

Genau, mehr gibt’s da glaube ich nicht.


#7

die Leistung zu reduzieren ist auch nur “Krücke”

Nein, die Krücke ist WLAN Roaming. Leistung reduzieren ist das was du willst da du ja nicht möchtest das der Client klebenbleibt.

Bei 40Mhz hast du nur 2 Kanäle, in der Stadt eher keinen.