Karte ausgerollt aber funktioniert nicht


#1

Moin. Unter http://karte.freifunk-lippe.de soll unsere neue Karte erreichbar sein.

Leider gibt es beim Aufruf lediglich die Meldung: “Error: Not Found”.

Ein “batctl -m batXX o” liefert mir aus jeder Domäne Knotendaten.

Kann jemand helfen?


#2

@corny456, @descilla, ich bin im neuen Kartenserver noch nicht so drin. Früher wurde fast alles über die Skripte generiert.

Welche Dienste müssen laufen und wie kann man ggfs. eine Neu- oder Erstgenerierung der Kartendaten erzwingen?

Grüße
Matthias


#3

Der Reverse Proxy vom nginx der /data/ auf 127.0.0.1:4000 umleiten soll funktioniert nicht.
Der hopglass-server Läuft auch…
http://karte.freifunk-lippe.de:4000/nodes.json

Eine neu Generierung der Kartendaten gibt es nicht da diese on-the-fly generiert werden wenn sie jemand anfordert.


#4

Was kann ich am Reverse Proxy überprüfen?


#5

Kann es sein das die gesamte


Nicht enabled ist?
Die Rewrites von map01 etc gehen auch nicht…
Wie sieht die Datei aus und was gibt
ls -la /etc/nginx/sites-enabled
Aus?


#6

http://pastebin.com/K3RUcWdW

Die Ausgabe:

root@karte ~ # ls -la /etc/nginx/sites-enabled
total 8.0K
drwxr-xr-x 2 root root 4.0K Mar 18 18:01 .
drwxr-xr-x 5 root root 4.0K Mar 18 18:01 …
lrwxrwxrwx 1 root root 34 Mar 18 18:01 default -> /etc/nginx/sites-available/default
lrwxrwxrwx 1 root root 38 Mar 18 18:01 default_ssl -> /etc/nginx/sites-available/default_ssl


#7

Ich musste nginx updaten. Vorher war die 1.6.2 drauf, nun ist die Version 1.10.3.
Kann das etwas mit dem Problem zu tun haben?


#8

Könnte sein.
Guck Mal in die /etc/nginx/nginx.conf ob da unten zwei includes vorhanden sind. Falls es nur einer ist füge ein
include /etc/nginx/sites-enabled/*;
Hinzu.


[gelöst] Fehler beim Beantragen des Letsencrypt-Zertifikates
#9

Das stand tatsächlich nicht drin. Muss nur nginx neu gestartet werden oder noch etwas?

Edit: habe rebootet. Läuft leider immer noch nicht.


#10

Nur der nginx.
Er lädt scheinbar immer noch nicht die richtige default_ssl config… HTTPS geht auch noch nicht was darauf schließen lässt.

@descilla hast du noch ne Idee?


#11

/etc/nginx/nginx.conf sieht so aus:

http://pastebin.com/FYSdKyKU


#12

Problem ist behoben Aus irgendeinem Grund ware die beiden Dateien unter /etc/nginx/sites-available zwar vorhanden, aber ohne Inhalt.

Ich habe den Inhalt der Templates hineinkopiert und angepasst.

Jetzt läuft alles.

Vielen Dank für eure Hilfe.


#13

Etwas habe ich noch: wo kann ich die Zoomstufe der Knotenansicht ändern?
Und warum werden bei der Trafficstatistik “No Data Points” angezeigt und kein Graph?


#14

Ich glaube die Statistik muss der KnotenBetreiber für seinen Knoten aktivieren. Aber die Firmware dafür ist noch nicht verfügbar.

@corny456 korrigiere mich, wenn ich falsch liege.


#15

Nicht ganz… Wir erfassen die advanced-node-stats aus Datenschutzgründen nicht pauschal von allen Knoten sondern nur von denen die sich in einer Whitelist eingetragen haben.


#16

mapSigmaScale heißt der Parameter.
Steht schon auf meiner Todo das Variable zu machen…


#17

Ja, für die Haupt-Kartenansicht. Ich meine die Ansicht der Karte rechts, wenn man einen Knoten anklickt.


#18

Achso. Das ist noch eine kleine Änderung die @descilla gemacht hat und noch nicht upstream im repo angekommen ist glaub ich…


#19

Das bedeutet die Trafficgrafik gibt es nur in Verbindung mit advanced-node-stats ? Gibt es eine Möglichkeit, das für alle Knoten freizuschalten ohne eine Whitelist führen zu müssen?


#20

Möglich: sicherlich.
Gewollt: Nein.
Grund: Datenschutz, sagte corny doch.