Kein DHCP vom FF-Router


#1

Hallo in die Runde,

unser Problem ist, dass unser Freifunkrouter keine IP-Adressen an die Clients verteilt. Mein Android-Smartphone zeigt “IP-Adresse wird abgerufen…”, mein Windows-Laptop gibt sich eine APIPA-Adresse.

Wir haben an vielen unserer Standorte bereits Freifunk installiert. Bislang habe ich immer die FF-Router (TP-LINK 841n) direkt an unsere Internet-Router (Lancom 800+ oder 1781VA) angeschlossen, teilweise mit einem Switch dazwischen. Bei den Lancom-Routern ist DHCP grundsätzlich abgeschaltet, da die daran angeschlossenen Proxyserver mit einer festen IP ausgestattet sind.

Bei meiner Installation in Münster habe ich einen vergleichbaren Aufbau versucht, mit oben beschriebenem Misserfolg. Nun habe ich (als Zwischenlösung) den Router in unser Netzwerk gehängt, was durch den hier vorhandenen DHCP-Server dann auch funktioniert.

Mit dieser Lösung sind wir jedoch nicht zufrieden, da wir so nicht steuern können, über welche unserer zwei Internetleitungen der FF-Router sein VPN aufbaut.

Habt Ihr eine Idee?


#2

Der FF-Knoten benötigt ja eine IP-Adresse in Deinem hauseigenen LAN, damit er als “Rechner” im Netzwerk vorhanden ist und eine Internetverbindung aufbauen kann.

Das er das nicht kann siehst Du daran, dass die Clients dann keine IP-Adresse bekommen, da diese vom FF-Server vergeben werden. Die Konfig des FF_Routers scheint ja schon mal OK zu sein, wenn er in einem Netz mit DCHP funktioniert.

Also muss Du die MAC-Adresse in Deinem Netz registrieren und dieser eine feste IP zuweisen, sowie diesen dann über den [entsprechenden Port] 1 ins Internet lassen.


#3

Hallo @Kean,

hast du denn mal versucht dem FF-Router in den Experteneinstellungen im Config Mode eine Feste IP zu geben? Wenn der Router keine IP / DNS und Gateway Adresse bekommt kann er sich nicht zu unseren Servern verbinden. Der FF-Router verhält sich WAN seitig wie ein ganz normaler Netzwerkteilnehmer wie z.b. ein PC.

Gruß Marius

Edith sagt:
mist @dippydipp war schneller :wink:


#4

@corny456 Die Idee mit der festen IP über die Experteneinstellungen ist aber auch nicht schlecht.


#5

Hallo @Kean,

ich benötigte den Namen des Knotens, schick mir am Besten den Link dazu auf der Karte. Dann kann ich mir das mal ansehen.

Grüße
Matthias


#6

Hallo Matthias,

wenn ich den Link des Routers auf der Karte kopiere, bekomme ich nur die URL der Karte in die Zwischenablage…

Der Router heißt DAA_MS01-208, vielleicht reicht dir das als Info.

Herzliche Grüße

Andreas


#7

http://map.freifunk-muensterland.org/maps/map01/#!v:m;n:60e327bd8f32 :wink:


#8

Hallo Matthias,

ich habe gerade schon im Forum geantwortet…

Aber gern auf diesem Weg:

Der Knoten heißt DAA_MS01-208, der Nachbarknoten (DAA_MS01-206) ist nur über W-LAN mit dem ersten verbunden, da ich am Aufstellungsort keinen LAN-Anschluss habe. Weitere Geräte werden am Standort folgen, dann hoffentlich mit eigenem Anschluss ans Internet.

Herzliche Grüße

Andreas Keßler
[Daten durch Moderation entfernt]

Internet: http://www.daa-owl.dehttp://www.daa-owl.de/


#9

Der DHCP-Server läuft und vergibt Adressen.

  • Hast du es mal mit einem anderen Gerät probiert?
  • Kannst du mir die Mac-Adresse von dem Gerät geben, was nicht funktioniert? Dann gucke ich mal, ob hier Anfragen durchkommen.

Grüße
Matthias


#10

Vielleicht habe ich mich nicht richtig ausgedrückt. Ich versuche, mein Problem mal genauer zu formulieren:

Ich hätte gern folgende Lösung:

Internetleitung1 --> LANCOM-Router1 --> FF-Router
Internetleitung1 --> LANCOM-Router1 --> Proxyserver1 --> LAN
Internetleitung2 --> LANCOM-Router2 --> Proxyserver2 --> LAN

wobei die LANCOM-Router kein DHCP machen (weil wir das nicht benötigen). So habe ich das beispielsweise hier in Bielefeld konfiguriert.

Jetzt habe ich die (Zwischen-) Lösung so aufgebaut:

Internetleitung1 --> LANCOM-Router1 --> Proxyserver1 --> LAN --> FF-Router
Internetleitung2 --> LANCOM-Router2 --> Proxyserver2 --> LAN --> FF-Router

wobei LAN in beiden Fällen das selbe ist, der FF-Router bekommt seine IP-Adresse jetzt von unserem DHCP-Server im LAN. Was mir nicht gefällt ist, dass ich so nicht steuern kann, über welche Internetleitung FF bereit gestellt wird. Aus Gründen, die ich jetzt nicht im Detail erläutern möchte (zu ausschweifend und nicht zielführend), würde ich gern die FF-Router direkt an einem der beiden LANCOM-Router betreiben, um die Bandbreite der anderen Leitung frei zu halten.

War das verständlich? Sonst rücke ich noch mehr Infos raus. :wink:

An dieser Stelle erst einmal vielen Dank für eure Antworten und die schnelle Reaktion sowie Matthias’ Hartnäckigkeit und Hilfsbereitschaft!

Herzliche Grüße

Andreas


#11

Hallo Andreas,

es geht also gar nicht darum, dass die Geräte im WLAN „Freifunk“ keine IP bekommen, sondern es geht um die IPV4 in eurem privaten Netzwerk?

Du kannst im Konfigurationsmodus den Freifunkrouter auf eine feste IPV4 einstellen. Resetknopf gedrückt halten bis alle LEDs aufleuchten -> loslassen -> per LAN an einen der gelben Ports -> Router gibt dir eine IP aus 192.168.1.0/24 -> http://192.168.1.1/ -> Rechts oben erweitert -> Und dann glaube ich im Reiter Netzwerk kann man auf statisch stellen.

Ist es das, was du suchst?

Oder willst du an die LAN-Ports einen Rechner anschließen, der ins Freifunk soll? Das ist bei uns standardmäßig deaktiviert und kann unter demselben Reiter aktiviert werden, indem das Häkchen „Mesh auf dem LAN-Port“ deaktiviert wird (das unterste).

Grüße
Matthias


#12

Hallo!

Das selbe Problem habe ich auch, ich habe auch zwei Internet Anschlüsse die ich in mein lokales Netzwerk über zwei Router verbunden habe. Bein ersten Router ist der DHCP-Server eingeschaltet und stellt im Netzwerk IP-Adressen zur Verfügung. Im zweiten ist der DHCP-Server aus. Nun habe ich im Netzwerk einen Freifunkrouter den ich eine feste IP-Adresse gegeben habe und dieser soll über den zweiten Router ins Internet gehen. Als Gateway und als DNS habe ich die IP-Adresse von den zweiten Router eingetragen. Mit der alten Firmware von der Domäne 4 hat dieses auch immer so Funktioniert. Wenn ich jedoch jetzt auf eine neue Domäne mit L2TP update verbindet sich der Freifunkrouter nicht mehr mit den Freifunkserver. Es sind in den Routern keine Ports blockiert.

Gruß
Crash


#13

Simplizier mal den Aufbau. Steck mal einen der beiden Router ab und probiere es nur über den anderen.

Ich vermute, dass da irgendeine Art von Loadbalancing läuft, die nicht mit L2TP zurecht kommt.

Wenn du mir deine Knoten-ID gibst, kann ich mal nachsehen, ob überhaupt ein Anmeldeversuch stattfindet.