Meshprobleme (2x)

Moin,

in den letzten zwei (?) Wochen hatte ich drei Mal folgende Symptomatik:

  • 3-Mesh-only Router in “meinem” 4-Router-Mesh-Netz werden in der Karte als offline angezeigt
  • Der Router, der am DSL hängt (“VPN-Router”, http://[2a03:2260:115:3900:ea94:f6ff:fe78:cb08]/) bleibt online und zeigt auch seine Statusseite (ohne Mesh-Verbindungen)
  • Das Problem ist kein Problem der Kartendarstellen o.ä.; ich bekomme von den Mesh-Knoten tatsächlich keine IP; sie sind tatsächlich nicht mit dem VPN-Router verbunden
  • Das Problem heilt nicht von selbst innerhalb eines Tages oder so.
  • Neustart des VPN-Routers behebt das Problem sofort (zuletzt heute, ca. 18:51 Uhr); Neustart der Mesh-Router ist nicht notwendig.

Möglicherweise haben wir das selbe Problem auch in der Installation von @cplus gesehen. Dieser Router: http://[2a03:2260:115:3900:a62b:b0ff:fead:a258]/ ist ebenfalls der VPN-Router für ein Mesh-Netz (mit 5 weiteren Routern) und musste ebenfalls 2x innerhalb der letzten 8 Tage neu gestartet werden und 1x (am 2.7.) hat er sich selber geheilt nach einem halben Tag oder so.

Wie könnte man hier weiterkommen? In “meinem” Test-Netz ist es nicht so schlimm, aber außerhalb schon recht nervig. Kann ich da noch etwas debuggen oder gibt es kluge Ideen?

Cheers

Mike

nabend,

ich würde ggf, mal ein einfaches Ausschluss-Szenario durchspielen:

nehme einen deiner Meshrouter und verwende diesen als VPN-Router. den VPN Router packst du einfach mal in das Mesh Netz statt den VPN. (evtl vorher konfigurieren, falls Einstellungen nicht korrekt sein sollten)

Man kann natürlich speukulieren (Fehler in Firmware, Fehler an zusammenhängender Netzinfrastruktur, aber das würde ich evtl mal versuchen mit dem Tausch (Koordinaten und Name müsste man evtl bei beiden tauschen, lässt sich ja aber mit Konsole schnell erledigen.)

Häng dich doch mal per Kabel an einen der Mesh Router und guck mal was da so auf der wlan Schnittstelle ankommt, so per tcpdump.

Danke für die Ideen. Werde ich beide ausprobieren nur leider oder gottseidank wird es vermutlich ein paar Tage dauern, bis das Problem in meinem Test-Netz wieder auftritt. Bei dem anderen Netz, wo wir nicht so gut drankommen und probieren können, war heute anscheinend wieder so ein Ausfall. Alle Ideen zu Remote-Debugging-Ansätzen daher weiterhin willkommen…

Um es dann alles richtig zu machen, Dein Vorschlag mit meinen einfacheren Worten:

  • Ich warte bis das Problem wiederkommt
  • Ich verbinde mich mit einem der “abgehängten” Router per LAN-Kabel über die gelbe Buchse
  • Connect via SSH auf IPV6 des Routers
  • Dann “irgendwie” (siehe google) tcpdump so ausführen, dass alle Kommunikation über die WLAN-Schnittstelle in eine Datei geschrieben wird
  • Klug in diese Datei gucken und dann hilflos im Forum posten :slight_smile:

Richtig verstanden?

ja, dafür musst du aber vorher tcpdump (auf dem Knoten) installiert haben.

1 Like

Viele Geräte haben für tcpdump-mini zu wenig NVRAM. Ein stark abgespecktes tcpdump lässt sich aber mittels batctl td <interface>, also z. B. batctl td eth0 aufrufen. Standardmäßig landet die Ausgabe dann im Terminal.

1 Like