[Probelm]Android Verbindungsabbrüche


#1

Hallo liebe Freifunker,

nachdem ich mir mal ein neues Handy zugelegt habe, wurde auch ich jetzt Opfer der ominösen Android Verbindungsabbrüche.

Das Problem: Wenn die Verbindung länger nicht genutzt wurde oder man aber den AP* gewechselt hat (Roaming) hatte man zwar eine IP, und auch Verbindung zu Knoten und GW**, aber weiter kam man nicht. Betrifft wohl einige Geräte vor allem ab Android 5.X und höher.

Meine Lösung:

Es gibt in den Entwickleroptionen die Option “WLAN-Roaming-Scans erlauben”. Die habe ich aktiviert. Damit geht die Verbindung nicht mehr verloren. Ist getestet auf Android 5 und Android 6 und in Domäne 10 und 01. Da ich nicht unendliche finanzielle Möglichkeiten habe, konnte ich das bisher nur auf 3 Geräten testen.

Wie aktiviert man diese Option:

  1. Den Punkt Buildnummer 7 mal antippen. Damit werden die Entwickleroptionen freigeschaltet. (Zu finden in Geräteinfo>Softwareinfo)

  1. Entwickleroptionen aufrufen und aktivieren.

  1. Option aktivieren.

Anmerkung: Die Einstellungen werden deaktiviert wenn man das Handy neustartet.

Ich würde mir wünschen, wenn auch noch mehr Personen das testen und Feedback geben könnten. Vorallem natürlich Betroffene. :wink:


#2

Ich kann bestätigen, dass das auch einen Teil meiner Probleme gelöst hat. Ich konnte heute doch tatsächlich das erste mal zum BellaVita und zurück roamen. So ergibt Freifunk gleich viel mehr Sinn. Danke für den Tipp, @Alucardo!


#3

Ok kleines Update:

Konnte heute das Problem auf IPV4 eingrenzen. Habe mein Handy mich mal benachrichtigen lassen wenn 8.8.8.8 nicht mehr erreichbar ist. Mir ist dann aufgefallen, dass Dienste mit IPV6 (Youtube, Google) weiterhin nutzbar waren. Evtl. wirklich ein Problem mit dem DHCP-Lease? (Vermutung von adorfer im großen Forum)

Somit ist auch die Vermutung, dass das mit der IP selbst zu tun hat vom Tisch, da ich in der Testdomäne 65 war. (Hatte 192.168.0.29 zu dem Zeitpunkt)

@Adminteam Was passiert wenn man die DHCP-Leasetime auf 24h hochsetzen würde? (aktueller Wert 3600 = 1h?)

edit: Das Roamen funktionert aber hervorragend^^


#4

In Domäne 65 kann ich die beliebig einstellen. Was hättest du gerne als normalen Zeitraum und was als maximalen? Ein und zwei Tage?


#5

Perfekt dann wird sich ja zeigen ob das hilft.

BTW jeder darf gerne mittesten. :wink: