Warendorf - 802.11s Test

#1

Fortsetzung der Diskussion von [gluon] [ANNOUNCE] Gluon v2016.1:

In Warendorf versuchen wir mal das 802.11s … Irgendwann kann man damit ja anfangen… Wie nehmen gleich eine schwierige Ecke.

1 Like

#2

@HorstKevin, der ffwaf-Oststr36 muss seeeehr ungünstig stehen. Könnt ihr da vielleicht mal schauen?

0 Likes

#3

Ja, oder ich muss mal meine Nano neu ausrichten. Ich kümmere mich morgen darum.

0 Likes

#4

Die Firmware hilft dir jetzt beim Ausrichten. Schau dir die Status-Page mal an.

0 Likes

#5

Ja das ist schön. Aber irgendwie kann ich es nur noch verschlimmbessern. Ich werde mal die Geräte auf der anderen Seite mit größeren Antennen ausstatten. Dazu muss ich aber 2 ND Router bestellen. Schaun wir mal. Vor der Kirche gibts jetzt auch FF.

0 Likes

#6

Da sind dicke Wände… Kein Mesh mit dem Warintharpa. Und das Netz vom Warintharpa ist bei Wiese auch schon nicht mehr zu fassen … Dieses schäbbige WLAN!

0 Likes

#7

Ich habe mal http://[2a03:2260:115:1400:62e3:27ff:feee:2d88]/ auf 802.11s only umgestellt und bei den Nachbarn 802.11s aktiviert. Falls was schief geht, bricht nicht gleich alles zusammen, da der Node halbwegs redundant ist.

0 Likes

#8

…und den Test wieder beendet. Da ich nicht die gesamte Wolke umstellen kann, läuft alles wieder im Ausgangszustand. Ich habe den Eindruck, dass die 802.11s-Verbindungen an Knoten mit “Mischbetrieb” doch deutlich das Nachsehen haben (was technisch betrachtet wohl auch keine Überraschung ist).

0 Likes

#9

Warum ist das keine Überraschung?

0 Likes

#10

Ich hatte zumindest vermutet, dass da das Hidden-Node-Problem zuschlägt und 802.11s dann nicht zur Geltung kommen kann.

Jetzt läuft die gesamte Wolke auf 802.11s. Die Durchsatzsteigerung am Uplink (WLAN-Mesh) liegt “gefühlt” zwischen 50…100 %. :grinning:

https://service.freifunk-muensterland.de/maps/map14/#!v:m;n:f4f26d303de6

EDIT: Am Uplink gingen vorher im Tagesmittel um die 700 kBit/s durch. Nach einer Stunde liegt der Wert jetzt bei 1,46 MBit/s.

Ein ganz dickes Dankeschön für die Arbeit, das hat uns spürbar was gebracht! :blush:

0 Likes

#11

Probleme gab es noch mit verschiedenen Versionen von /etc/config/network. Nachdem ich die mesh_radio-Einstellungen von den “frisch” geflashten Routern übernommen habe, passte es. Die von stable auf latest migrierten Knoten hatten folgende Konfiguration

config interface 'mesh_radio0'
  option proto 'none'
  option mtu '1536'

config interface 'mesh_radio0_vlan'
  option ifname '@mesh_radio0.4'
  option mesh 'bat0'
  option proto 'batadv'
  option mtu '1532'

Die neueren die folgende Einstellung

config interface 'mesh_radio0'
  option mesh 'bat0'
  option proto 'batadv' 
  option mtu '1532'
0 Likes

#12

Oh. Shit! Muss ich mal schauen…!

0 Likes

#13

Welche ist denn die “richtige”?

0 Likes

#14

Das vlan sollte nur beim adhoc sein. Die zweite ist die richtige… Mal sehen, wie ich das migriert bekomme…

1 Like

#15

Im latest heißt das alte mesh jetzt ibss. Da funkt was bei der Migration nicht, wenn das vlan erhalten bleibt …

Sieht so aus, als ob “uci del network.mesh_radio0_vlan” das Problem schon fixt. Das Problem gibt es sicherlich nur in domäne-14, also Kreis Warendorf, denn nur da wurden im ibss, früher adhoc genannt, ein vlan genutzt. Weg von ibss, früher adhoc, hat auch den kleinen Vorteil. dass das adhoc Netz nicht mehr angezeigt wird :smile:

Ich mal wieder den ganzen Tag rumgefumelt und eine neue „latest“ gebaut. Grund ist, dass die 2016.1 offenbar ein Problem mit einer Sonderwurst hat, die ich am laufen habe. Zum Debuggen werde ich mir wohl einen 1043er bestellen müssen. Die Software wird gerade hochgeladen, aber ihr müsst sie manuell installieren. Das ganze ist mir noch zu heiß, insb. wegen der Sonderwurst die nicht funktioniert. Wechselt mal ruhig nach dem Update auf 802.11s. Scheint insgesamt besser zu funktionieren.

Also, @Johannes, @jotzt, @HorstKevin, @woerde und @Alucardo: testen, testen, testen …

2 Likes

#16

@paulinsche ich habe gerade 2 1043 die neuen nzh1/2 hier stehen, dein Schlüssel ist drauf, da kannst du gerne dran rumfummeln…

0 Likes

#17

Es läuft schon der eine oder andere 1043. Was nicht funktioniert ist möglicherweise was mit den Tagging auf dem LAN. Große Pakete wollen nicht durch. In einem einfachen Fall scheint das zu klappen…

Aber ich fummel mal trotzdem :slight_smile:

0 Likes

#18

Teste gerne. Was soll ich tun? Neue Firmware auf alle vier Router? Die geht jetzt mit 841v9 und v10. Richtig verstanden? Dann benutzen und gucken, ob alles rund läuft. Mach ich heute abend dann…

Frage: beim letzten FW-Upgrade über ssh haben die Router am Ende in den Konfigmodus gewechselt. Da musste ich die Schätzchen mühsam ins Haus holen und an einen PC anschließen. Wie mache ich es diesmal besser?

  • Lag es daran, dass ich sysupdate - n gemacht habe? Kann ich das -n diesmal weglassen und verhindert das den Reboot in den Konfigmodus?
  • kann man das hübsche grafische anwenderfreundliche Konfigmenü eigentlich auch über das Netzwerk erreichen oder kann die Konfiguration remote nur per SSH verändern?
0 Likes

#19

Kurz: Ja!

AFAIK nein.

1 Like

#20

Also Zusammenfassung:

Der Router bootet. Danach kann kann das 802.11s aktiviert werden:

802.11s an:

set wireless.mesh_radio0.disabled='0'
wifi

Adhoc aus:

set wireless.ibss_radio0.disabled='1'
wifi

Permanent machen:

uci commit

Wenn alles gut funktioniert, dann soll es mal ein Image geben, das überall da wo adhoc-mesh aktiviert ist, dass 802.11s aktiviert wird. Wenn alle Router durch sind, wird es ein weiteres Image geben. in dem adhoc-mesh deaktiviert wird. Und wenn es dann noch ein Image gibt, dann ist ist das ganz ohne adhoc-mesh Unterstützung. Wer mag, kann den Plan verbessern.

0 Likes