Freifunk in Turnhalle inkl. Tribüne, Frage nach Unterstützung


#1

Hallo liebe Freifunker,
wir evaluieren gerade eine Turnhalle inkl. Tribüne mit Freifunk auszustatten. Zur Verfügung stehen 200 MBit symmetrisch per Glasfaser vom Nachbargebäude. Zukünftig auch bei Bedarf mehr.
Als Hardware würden wir gerne UniFi APs einsetzen, da wir diese in anderen Bereichen auch schon verwenden.

Als VPN-Offloader dient ein Siemens Futro S550-2 mit 2 NICs und 2 Gig Ram, alternativ eine FritzBox 4040. Persönlich würde ich aber den S550 vorziehen.

Kann uns hier jemand helfen den Futro bzw. die FritzBox entsprechend als Offloader zu konfigurieren? Gerne komme ich mit der Hardware auch vorbei bzw. stelle einen Raum zur Verfügung. Alternativ die Frage woher ich ein passendes Image für das Münsterland bekomme?

Anbei noch ein Skizze von der Planung.47


Firmware Freifunk Dom13 Firtzbox 4040
#2

Ich kann dir gerne helfen. Wo ist denn die Halle?


#3

Hi, stimmt - das Detail ist natürlich auch relevant. In Coesfeld. Ich kann aber auch mit der Hardware auf Reise gehen.


#4

Moin @LinuxLinus und willkommen im Forum,

klar. Das geht quasi wie jeder normale Router auch.

Ich nehme an, du hast die zwei Netzwerkkarten schon eingebaut? Ich würde den Futro mit dem berühmten Gluon2Futro-Skript fläschen: https://github.com/oszilloskop/Gluon2Futro

Aber Obacht, die Warnung da ist ernst zu nehmen. Der Stick bügelt einfach die erste Festplatte über. Wenn man davon einen PC bootet, sind alle Daten futsch.

Dann kommt der interessante Teil:

Du brauchst sowohl Mesch (für die FB4040 bzw. die AC Mesh für draußen) als auch Clientnetz für die Unifis für drinnen.

Dazu wird einfach in der /etc/config/network die VLAN-Konfiguration hinterlegt. Der PoE-Switch sollte auch VLANs können, und dividiert das dann wieder auseinander, Clientnetz an die Unifis und das Meschnetz an die Unifi.

Hier eine Beispielkonfiguration dazu: (relevante Zeilen mit ###<<< markiert)

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd88:a3ea:4221::/48'

config interface 'wan6'
	option proto 'dhcpv6'
	option sourcefilter '0'
	option ifname 'br-wan'
	option ip6table '1'
	option peerdns '0'

config interface 'wan'
	option igmp_snooping '1'
	option ifname 'eth1'
	option multicast_querier '0'
	option peerdns '0'
	option auto '1'
	option type 'bridge'
	option proto 'dhcp'
	option macaddr '36:5d:51:14:15:b0'

config rule6 'wan6_lookup'
	option mark '0x01/0x01'
	option lookup '1'

config route6 'wan6_unreachable'
	option type 'unreachable'
	option table '1'
	option target '::/0'
	option metric '65535'
	option gateway '::'
	option interface 'loopback'

config interface 'mesh_wan'
	option ifname 'br-wan'
	option auto '0'
	option transitive '1'
	option fixed_mtu '1'
	option proto 'gluon_mesh'

config interface 'mesh_lan'
	option igmp_snooping '0'
	option ifname 'eth0.2'  ###<<<<<<<<<<<<hier VLAN2 Meschnetz
	option transitive '1'
	option fixed_mtu '1'
	option proto 'gluon_mesh'
	option type 'bridge'
	option auto '1'
	option macaddr '36:5d:51:14:15:b4'

config interface 'client'
	option igmp_snooping '1'
	option type 'bridge'
	option auto '1'
	option multicast_querier '1'
	option macaddr '10:fe:ed:03:85:30'
	option ipv6 '1'
	option keep_ra_dnslifetime '1'
	option sourcefilter '0'
	option peerdns '0'
	option robustness '3'
	option reqprefix 'no'
	option query_interval '2000'
	option query_response_interval '500'
	option proto 'dhcpv6'
	list ifname 'local-port'
	list ifname 'bat0'
    list ifname 'eth0.3' ###<<<<<<<<<<<< VLAN3 Clientnetz

config device 'local_node_dev'
	option type 'veth'
	option name 'local-node'
	option peer_name 'local-port'
	option macaddr 'de:ad:be:ef:08:01'
	option peer_macaddr '10:fe:ed:03:85:30'

config interface 'local_node'
	option ifname 'local-node'
	option ipaddr '10.5.0.1/16'
	option ip6addr '2a03:2260:115:500::1/128'
	option ip6deprecated '1'
	option proto 'static'

config interface 'gluon_bat0'
	option proto 'gluon_bat0'

config interface 'bat0'
	option multicast_router '2'
	option ifname 'bat0'
	option auto '1'
	option macaddr '10:fe:ed:03:85:30'
	option learning '1'
	option proto 'none'

config route6 'local_node_route6'
	option target '2a03:2260:115:500::/64'
	option gateway '::'
	option interface 'client'

config interface 'mesh_vpn'
	option ifname 'mesh-vpn'
	option transitive '1'
	option mtu '1364'
	option macaddr '36:5d:51:14:15:b7'
	option fixed_mtu '1'
	option proto 'gluon_mesh'

Ungetestet, sollte aber hinhauen.

Wichtig, ein Passwort setzen oder einen SSH-Schlüssel setzen. Da die Futros keinen Restknopf haben, kommt man da sonst nicht mehr dran.

Viele Grüße
Matthias


#5

Hallo,
ich habe heute morgen gebastelt, der Futro ist online mit der NodeID 0019999a6ce7. Mir ist aber nicht ganz klar wie es nun weitergehen soll.
Die Config habe ich ich eingespielt:

root@Schul-IT-DFTH:~# ifconfig 
bat0      Link encap:Ethernet  HWaddr 10:FE:ED:03:85:30  
          inet6 addr: fe80::12fe:edff:fe03:8530/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12977 errors:0 dropped:0 overruns:0 frame:0
          TX packets:340 errors:0 dropped:33 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1056400 (1.0 MiB)  TX bytes:39732 (38.8 KiB)

br-client Link encap:Ethernet  HWaddr 10:FE:ED:03:85:30  
          inet6 addr: 2a03:2260:115:4600:12fe:edff:fe03:8530/64 Scope:Global
          inet6 addr: fe80::12fe:edff:fe03:8530/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1814 errors:0 dropped:0 overruns:0 frame:0
          TX packets:209 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:86144 (84.1 KiB)  TX bytes:30528 (29.8 KiB)

br-mesh_lan Link encap:Ethernet  HWaddr 36:5D:51:14:15:B4  
          inet6 addr: fe80::345d:51ff:fe14:15b4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16639 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:1875932 (1.7 MiB)

br-wan    Link encap:Ethernet  HWaddr 36:5D:51:14:15:B0  
          inet addr:10.0.0.165  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::345d:51ff:fe14:15b0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22704 errors:0 dropped:152 overruns:0 frame:0
          TX packets:5625 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3653865 (3.4 MiB)  TX bytes:1013361 (989.6 KiB)

eth0      Link encap:Ethernet  HWaddr 00:19:99:9A:6C:E7  
          inet6 addr: fe80::219:99ff:fe9a:6ce7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:430 errors:0 dropped:1 overruns:0 frame:0
          TX packets:18335 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:51494 (50.2 KiB)  TX bytes:1978938 (1.8 MiB)

eth0.2    Link encap:Ethernet  HWaddr 00:19:99:9A:6C:E7  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16639 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:1875932 (1.7 MiB)

eth0.3    Link encap:Ethernet  HWaddr 00:19:99:9A:6C:E7  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1689 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:102188 (99.7 KiB)

eth1      Link encap:Ethernet  HWaddr 3C:49:37:17:FD:E0  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22725 errors:0 dropped:21 overruns:0 frame:0
          TX packets:5625 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3973716 (3.7 MiB)  TX bytes:1013361 (989.6 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:995 errors:0 dropped:0 overruns:0 frame:0
          TX packets:995 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:64815 (63.2 KiB)  TX bytes:64815 (63.2 KiB)

mesh-vpn  Link encap:Ethernet  HWaddr 92:36:A3:50:3E:ED  
          inet6 addr: fe80::9036:a3ff:fe50:3eed/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1364  Metric:1
          RX packets:18510 errors:0 dropped:1 overruns:0 frame:0
          TX packets:4448 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2223822 (2.1 MiB)  TX bytes:526640 (514.2 KiB)

primary0  Link encap:Ethernet  HWaddr 56:A9:8C:88:30:F3  
          UP BROADCAST RUNNING NOARP  MTU:1532  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16497 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:1869776 (1.7 MiB)

Konfiguriere ich jetzt einfach die Unifi-APs ganz normal und erzeuge eine SSID “Freifunk” und gebe den Futro als Gateway an. Wer spielt in diesem Fall DHCP-Server?


#6

Der DHCP läuft auf unseren Gateways und diese sind auch das Standard-Gateway. Wir betreiben einen Unifi Controller im Freifunk Netz den wir interessierten zur Verfügung stellen. Wenn du möchtest richten wir dir eine Site ein, du kannst die Unifis einfach ins Freifunk Client Netz Hängen und über den Controller konfigurieren. Das die SSID “Freifunk” lautet ist in diesem Fall Bedingung. Soweit wenn du die Geräte mit original Firmware betreiben möchtest. (Was in meinen Augen absolut Sinn macht) Desweiteren muss mindestens an einer sinnvollen Stelle Freifunk-Mesh angeboten, also mit Freifunk Firmware betrieben werden.


#7

Danke für die schnelle Antwort!

Also müsste ich, mit der config von oben, auf der zweiten NIC per DHCP Adressen bekommen? Das ist aktuell nicht der Fall.

Einen Controller betreiben wir selber, dort haben wir bereits divers Sites angelegt so das ich gerne die APs auch unseren Controller betreiben möchte. Wenn es aber zum Einstieg sinnvoll ist können wir unsere APs auch gerne auf euren Controller einrichten uns später umziehen.

Zwei AC Mesh u. die SSID Freifunk werden wir selbstverständlich verbauen/anlegen.


#8

Das ist anhand dessen was du da oben gepostet hast nicht ersichtlich. Wenn du es so konfiguriert hast wie von Matthias vorgeschlagen dann hast du jetzt auf der 2. Netzwerkkarte im VLAN 3 das Client-Netz. Du brauchst dann hinter dem Futro einen VLAN Switch der auf dem Port der zum Futro geht tagged VLAN 2 und 3 entgegen nimmt und an dem Ports an denen die Unifis hängen das VLAN 3 und an den Ports an denen die AC Mesh hängen VLAN 2 untagged ausgibt.

Das geht nur dann wenn die Unifis auch in eurem Netz Hängen. Und es führt kein Weg mehr um eine Installation mit VLAN switch herum.


#9

Ich schaue mir die VLANs nochmal genauer an. Werde dazu aber erst Montag kommen.

Zu dem Controller: Unser Controller hat eine öffentliche IP, sollte somit doch auch aus dem Freifunk-Netz erreichbar sein. Oder übersehe ich da ein Problem?


#10

Das geht natürlich auch. Jedoch nur wenn man die Unifis manuell an den Controller bindet. Das geht dann nicht automatisch.


#11

Moin @LinuxLinus,

der Befehl ist tot, einfach nicht mehr verwenden bitte.

ip a

ist der neue Befehl dafür. Eine Kurzform für

ip address show

Standardmäßig kommt da Mesch raus. Das muss man erst umstellen. Du musst mit VLANs arbeiten, anders bekommst du nicht Client- und Meschnetz aus der zweiten Karte heraus.

Wir können uns das gerne mal zusammen per Tmux (geteilte Terminalsitzung) ansehen.

Nein, das funktioniert. Die Erkennung ist nur nicht automatisch. Unifi-Geräte suchen per Broadcast oder nach der DNS-Auflösung „unifi.default-domain“. Letztere zeigt im Freifunk-Netz auf unseren Controller. Hier ein Beispiel aus Domäne-01. Die Searchdomain weiß das Gerät über den DHCP-Server.

# dig @10.1.0.2 unifi.ffmsl.de +short
5.9.86.151

Dadurch erscheinen die Geräte automatisch bei uns. Du musst sie bei der Erstkonfiguration manuell auf deinen Controller hinweisen. Das geht per SSH und der Ubiquity-Support per Chat - erreichbar über den Controller links unten - hilft dabei.

Viele Grüße
Matthias


#12

Hi,
erstmal Danke für die schnelle Hilfe hier!

Ja, Gewohnheit :wink:

Falls es jemanden hilft, ganz einfach: per ssh als Nutzer ubnt mit mit Passwort ubnt auf die APs verbinden und

set-inform http://ip-of-controller:8080/inform

absetzen.

Dann habe ich es jetzt auch soweit Verstanden und am laufen: https://karte.freifunk-muensterland.de/map/#!v:m;n:0019999a6ce7.

Kann ich die erweiterten Knotenstatistiken noch per SSH aktivieren?
Und wird durch die Trennung der VLANs bereits verhindert, das sich Clients auf die AC Mesh verbinden? Ich möchte verhindern, das sich Clients mit den “schlechteren” AC Mesh verbinden und nicht die AP HDs nutzen.


#13

Noch nicht, das kommt in der Firmware 4.0, die bald (=vor Weihnachten 2020 ganz bestimmt) :innocent: rauskommt.

Die betreibst du mit Gluon für draußen? Du könntest das Clientnetz ausschalten und nur Mesch anbieten, das wäre aber schade.

Die Geräte wählen eigentlich automatisch den Besten Knoten, sodass du da nicht eingreifen musst.


#15

Wollte dir gerade antworten. Haben sich die Stabilitätsprobleme erledigt?


#16

Danke!
Nein, leider nicht. Ich wollte aber um die Übersicht zu bewahren ein eigenen Thread aufmachen - bin aber nicht mehr dazu gekommen.

Also zum Status: Der Link bei der zweiten Netzwerkkarte geht sowohl an der NIC als auch am Switch im Sekundentakt down - manchmal läuft es ein paar Stunden und dann ist es wieder vorbei. Verwendet wurde diese Karte: https://www.ebay.de/itm/DIGITUS-Gigabit-LAN-PCI-Netzwerkkarte-10-100-1000-DSL-Realtek-Low-Profile/362137033917?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

Ich habe daher jetzt die Config angepasst und auf eine Netzwerkkarte umgeschrieben (war ja leichter als gedacht). Damit scheint es jetzt zu funktionieren: https://karte.freifunk-muensterland.de/map/#!v:m;n:0019999a6ce7
Daran hängen aktuell zwei UAP-PRO, direkt zum Marktplatz in Coesfeld.

Wichtig ist mir vor allem, dass das ganze Setup später stabil läuft.

Parallel habe ich mir daher einen zweiten Futro und die folgende NIC gekauft:

Etwas in verdacht habe ich die erste NIC bzw. die Riser-Card. Daher habe ich auch eine zweite Riser-Card gekauft um nun alles tauschen zu können.

Bzgl, der Mesh-Funktionalität wird uns ein Elektriker ein vorhandenes Kable umlegen. Dann haben wir einen Platz für die Mesh direkt am Außenbereich - allerdings direkt neben einem Unifi AP HD. Da dieser sicherlich mehr Performance bietet könnte ich mir vorstellen, trotzdem auf dem Mesh nur das mesching laufen zu lassen - oder was meinen die Experten?

Besten Dank und viele Grüße!


#17

Hallo,

ärgerlich mit dem Futro. Das hatten wir bisher nicht. Wir haben Futros, die schon zwei Jahre stabil laufen. Welchen Treiber verwendet die D-Link-Karte? Kann auch sein, dass der Riser eine Macke hat. Wir haben immer soft-riser verwendet, also einfach so Flachbandkabel aus China quasi.

Die verlinkte Karte ist aber eh Schwindel. PCI kann kein Gigabit-Ethernet. Nur die Langversion.

Hat dein Futro keine PCIe-Schnittstelle? Der S550-2 müsste das haben. Wir haben sonst auch noch Futros, falls du einen haben möchtest.

Bzgl. der Außenkonfiguration: Wir verbauen derzeit immer Router im Doppelpack: AC Mesh Pro (mit Origianlfirmware nur für Clientnetz) und einen AC Mesh zum Meschen. Die Kombination kann man glaube ich (bisher nicht getestet) auch mit einem Kabel abwickeln, wiel man die Mesh hinter den Mesh Pro hängen kann.

Stören werden sich die Geräte nicht. Der AC-HD wird sich entsprechend einen anderen Kanal suchen.

Viele Grüße
Matthias


#18

Hi

Kann ich gerne nächste Woche schauen. Gerade komme ich nicht an den Futro (liegt im Büro) und die Karte ist nicht eingebaut. Wenn du mir deinen SSH-Key gibst kann ich den auch gerne hinterlegen.

Das hat mich dazu gebracht den zweiten gerade auch mal aufzuschrauben. Er hat auch nur PCI, kein PICe. Die Google Bildersuche zeigt aber auch nur 550-2 mit PCI.
Wo ich dabei war habe ich den neuen Futro auch direkt geflasht (Node ID: 001999b07664)
Was mich verwundert hat: Beim ersten habe ich zig Versuche gebraucht bis er vom USB Stick gebootet hat und am ende habe ich dann die CompactFlash Karte per DD und altem Kartenleser beschrieben. Bei dem zweiten lief alles direkt durch. Vielleicht hat er echt einen weg :frowning:

Da die Leitung zur Turnhalle mehr könnte wäre ich natürlich an mehr Speed interessiert.

Sehr sehr gerne. Dann könnte ein zweiter ggf. den Marktplatz versorgen. Soll ich mal in die Warpzone kommen oder kommen jemand zufällig Richtung Coesfeld?

Spannend, so werde ich es machen! Dann bin ich mal gespannt was passiert.

Besten Dank!


#19

@LinuxLinus welche AccessPoints genau setzt ihr ein? Für eine Sporthalle hätte ich an den UAP-ac-HD oder an die UAP-ac-M mit Sektorantennen gedacht. Oder laufen auch UAP-ac-Pro bei so großer Clientzahl gut? Hast du Statistiken/Auswertungen/Erfahrungswerte? Wäre für zukünftige Projekte interessant.


#20

Hi, ich bin dabei 14 Schulstandorte flächendeckend mit WLAN auszustatten - wir sammeln gerade daher viele Erfahrungen. Große Hallen sind aber auch neu, daher für mich gerade sehr spannend.

Was Reichweite und Performance angeht habe ich glaube ich ein ganz gutes Wissen. Was mir aber fehlt sind die Erfahrungen was ein Gast im Netz an Bandbreite braucht.

Status ist gerade, das die Halle per Glasfaser mit 200 MBit symmetrisch angebunden ist und wir dort den 16 Port PoE Switch eingesetzt haben.

Ich werde die Turnhalle mit Tribüne anfangs mit zwei UniFi AP HD ausstatten und bei größeren Veranstaltungen (Messen) weitere AP Pro hinzufügen.
Eine Halle ohne Tribüne wird von einem AP Pro versorgt, der reicht locker.

Wenn das nicht reicht würde ich auf die XG wechseln, die sind ja in den Dimensionen auch nicht überteuert.

Vielleicht bin ich verwöhnt oder habe hohe Ansprüche ans Netz. Trotzdem habe ich mich gewundert was eine einfache FritzBox 4040 in der Halle schafft. Diese hatten wir heute auf den Netzwerkschrank gelegt:
https://karte.freifunk-muensterland.de/map/#!v:m;n:e8df708af69c

Toll ist, das mein Büro zwei Fenster zum Marktplatz in Coesfeld hat. Somit kann ich dort auch gerade testen was die Reichweite angeht. Schade, dass das Wetter gerade nicht mitspielt.

Falls es der Community hilft gebe ich euch gerne Zugriff auf den Controller und den Futro.


#21

Das ist interessant, wir hatten sowas in Gütersloh Ende letzten Jahres auch: Futro als Offloader bzw. “Anbinder” an vorhandene Infrastruktur wurde vom städtischen Dienstleister gekauft, konfiguriert und aufgebaut. Aber das System kam nicht hoch. CF-Card in zweiten Futro (man hatte gleich Ersatz mitbestellt ;)) eingebaut. Verbindung klappt ebenfalls nicht. CF-Card erneut getauscht, neu bespielt. Nix. Schließlich umständlich Monitor angeschlossen, dort sah man dann das schon gepostete Bild. Habe dann letztlich einen Futro aus dem eigenen Fundus rangekarrt, hingestellt — tut.
Die beiden Futros habe ich dann vom Dienstleister überlassen bekommen, kam aber noch nicht dazu, näher zu gucken, was das Problem ist. Insofern interessant, daß es mit Futros auch anderswo (neuerdings) diese Probleme gibt; bis dato waren die hier völlig pflegeleicht.

Hmm? Ab PCI 2.2 sind 32 Bit bei 66 MHz spezifiziert, 266 statt zuvor 133 MByte/sec Busdurchsatz. Selbst mit den 32 Bit/33 MHz, die der Futro am PCI-Steckplatz lt. Specs nur liefert, sollte 1 GBit/sec dort gerade erreichbar sein. (Wobei da dann auch die Gegenstellen und Peers zumindest bei uns ggf. dicke Backen machen würden ;))