Support Ubiquiti NanoStation M2?


#21

Danke für den Link. Die dort verlinkte Datei
http://dl.ubnt.com/firmwares/XW-fw/v5.5.10/XW.v5.5.10-u2.28005.150723.1358.bin
entspricht aber laut sha256sum bitgenau der zuvor schon getesteten Datei, welche von den Magdeburgern auch verlinkt wurde.

Siehe gestern abend:

tftp> put XW.v5.5.10-u2.28005.150723.1358.bin
[…]
Error code 2: Firmware check failed


#22

Hattest du Mal das Abbild oderohne Xw getestet?


#23

Sorry, die Frage habe ich nicht verstanden.


#24

Hab es gerade korrigiert, meine ohne. Gibt ja zwei für die Nanostation. Ich glaube, dass du vllt. einfach das falsche Abbild erwischt hat.

Ich muss allerdings auch zugeben, dass ich lange keine Nanostation mehr gefläscht habe.


#25

In dem Video wird ein File namens ‘XW.v6.0.6-beta.30875.170526.0023.bin’ verwendet, welches ich von hier gezogen und getestet habe:
https://www.ubnt.com/downloads/XN-fw-internal/v6.0.6/XW.v6.0.6-beta.30875.170526.0023.bin

Vergleiche:

Das Hochladen dieser Datei wird mit dem Hinweis auf ‘ungültige Firmware-Datei’ abgelehnt.

Die Vorgehensweise aus dem Video ist damit ebenfalls gescheitert.


#26

Du meinst, ich sollte die XM* anstatt der XW* -Variante ausprobieren?
Bei ‘XM.v6.1.4.32113.180112.0932.bin’ wird das mit dem folgenden Hinweis geblockt: “Es wurde eine falsche Firmware-Version hochgeladen.”


#27

Okay, dann gibt es hier tatsächlich ein Problem mit dem Einspielen.

Du könntest mal die etwas neuere Version aus Domäne 54 (Ahaus) mit Lede probieren: https://firmware.freifunk-muensterland.de/domaene54/versions/v3.1.7-wr1043v5-exp/


#28

‘This firmware is not trusted by airOS. It will not be loaded. Please load trusted firmware.’

Scheinbar geht da nix ohne Signatur des Herstellers.


#29

Hattest du tftp probiert?


#30

Zuletzt nicht mehr, die heutigen Hinweise stammten vom Webinterface.

Gestern Nacht aber schon und da wurden auch schon Binaries abgewiesen.


#31

Ich befürchte, es ist das hier:
https://www.heise.de/newsticker/meldung/Funkregulierung-TP-Link-muss-WLAN-Firmware-sperren-3109847.html

Wenn das stimmt, haben zukünftig alle freien Netzwerke/Projekte ein massives Problem, weil sie von aktueller und zukünftiger Hardwareversorgung abgeschnitten sind.


#32

DECLARATION OF CONFORMITY
Ubiquiti Networks, Inc.
685 Third Avenue, 27th Floor
New York, NY 10017
USA
Hereby declares under our sole responsibility that the NanostationlocoM2, model locoM2, to which this
declaration relates, is in conformance with the provisions of Directives:
•Radio - 2014/53/EU Radio Equipment Directive (RED)
[…]
Mark Feil
Compliance Manager
October 24, 2017

Ja, ist die locoM2, aber ich vermute stark, dass das auch für die M2 gilt.

Vielleicht bin ich einfach nur einer der ersten Käufer?


#33

dl.ubnt.com/firmwares/XW-fw/v5.5.10/XW.v5.5.10.24238.141001.1641.bin hattest du diese schon?
es muss devenitiv ein xw versions sein nichts anderes und zum flashen benutze ich pumpkin1.0
hat bis jetzt bei allen geräten geklappt
oder hier https://www.dropbox.com/s/hhtrf9hf0iqpezu/XW.v5.5.10-u2.28005.150723.1358.bin?dl=0


#34

Nein, hatte ich noch nicht. Über das Webinterface:

“Es wurde eine falsche Firmware-Version hochgeladen.”


#35

Die hatte ich zumindest dem Namen nach schon in Beitrag #17 (21. Jan. um 01:07) via tftp.

EDIT: Laut sha256sum sind die beiden Dateien gleich.


#36

Hhmm, ich hatte den stinknormalen tftp-Client unter CentOS am Start. Würde mich wundern, wenn das einen relevanten Unterschied macht, zumal dies so auf den Support-Seiten auch dokumentiert wird.

EDIT: Eine Fehlermeldung wie
Error code 2: Firmware check failed
kommt ja auch nicht vom tftp-Client. IMHO ist es das System auf der M2, welches damit erklärt, dass es dieses Firmware-Paket nicht akzeptiert.


#37

hast du denn die möglichkeit die nano wieder auf die stockfirmware zu flashen


#38

Bin mir nicht ganz sicher, wie Du das meinst. Das hier hatte ja funktioniert:
tftp> put XW.v5.6.15-sign.31612.170908.1440.bin
Ich gehe davon aus, dass momentan alle signierten Pakete des Herstellers funktionieren werden, zumindest habe ich keine anderen Hinweise.


#39

was du jetzt brauchst ist ein xw image 5.5.10 damit du ein gloun verwenden kannst


#40

Wenn man der Anleitung aus Magdeburg folgt: Ja. Nur woher nehme ich die?

Diese hier habe ich bislang probiert:

bash-4.2$ ls -ltar 5.5.10
-rw-r–r--. 1 zuse 1000 6866114 6. Okt 2014 XW.v5.5.10.24238.141001.1641.bin
-rw-r–r--. 1 zuse 1000 6866199 20. Jan 23:14 XW.v5.5.10-u2.28005.150723.1358.bin
-rw-r–r--. 1 zuse 1000 6866199 21. Jan 10:21 XW.v5.5.10-u2.28005.150723.1358(1).bin
-rw-r–r--. 1 zuse 1000 6866199 21. Jan 19:04 XW.v5.5.10-u2.28005.150723.1358.bin.1

Größtenteils identisch, eine direkt von Ubiquiti.