Firmware 2.4.0 testen


#1

Da die 2.4.0 einige Verbesserungen gegenüber der 2.3.0 hat machen wir direkt mit der 2.4.0 weiter statt die 2.3.0 stable zu machen. [quote=“corny456, post:89, topic:1282”]
Basiert auf Gluon v2016.2.4 ansonsten alles beim alten…

BugfixesFix batman-adv (compat 15) not being able to transmit packages of specific sizes (b7eeef9)
We suspect that this issue was also the reason for the autoupdater/wget hangs observed by many communities. Non-Gluon nodes like gateways should be updated to batman-adv 2017.0.1 to get the fix.Fix build after ftp.all.kernel.org discontinuation (#1059)Fix high load because of frequent calls of the respondd initscript (9a0aeb9)
The respondd restart triggers added in v2016.2.3 ran a significant portion of the respondd initscript for each router advertisement received. This was fixed by a backport of a netifd patch.x86 sysupgrade fixes (41fd50d, ad37e2b)
This fixes sysupgrade on mmcblk and similar devices.
Other changesThe manifest generator has been extended to generate SHA256 checksums in addition to SHA512 ones (f9d59be)
We have recently switched the autoupdater to SHA256 in the Gluon master to avoid mixing two different lengths of hashes for no good reason. This makes the manifests of Gluon v2016.2.x compatible with the new autoupdater so it doesn’t prevent backports or downgrades.
Note: Downgrades of major Gluon versions are generally unsupported and will often lead to broken configurations.

http://gluon.readthedocs.io/en/v2016.2.4/releases/v2016.2.4.html
[/quote]


Firmware 2.3.0 testen
Firmware 2.3.0 testen
#2

2.4.0 scheint vernünftig zu laufen auf: Bullet M2, Rocket M2, Picostation M2, WRT841v9 und Futro.


#3

Ok, bitte für Dom13 in Experimental freigeben.


#4

Gleiches gerne wieder für die Dom12 (experimental)


#5

Macht doch alle Domänen Experimental frei, ich denke schon, das man erwarten kann, dass Router, deren Autoupdater, auf Experimental steht, bei Problemen, gut erreichbar sind und jemand betreibt der weiß was dass heißt und schnell eingreifen kann.


#6

stelle auf TLWR941ND auch keine Probleme fest. Außer, dass die Bandbreitennutzungsstatistik nicht funktioniert (FF-interner service fehler?)


#7

Hat mal jemand einen neuen Router getestet?

Die Weboberfläche soll nur noch auf Englisch sein. Ich meine, da hatte sich im Gluon was geändert, wir müssen das vermutlich noch anpassen bei uns, damit die deutschen Texte wieder verwendet werden.

Das würde bedeuten, dass wir eine 2.4.1 bauen müssten. Da könnte man dann Alfred direkt mal weglassen.


#8

Habe ein 841er kurz getestet. Da hat @MPW wohl recht. Habe es schon vor ein paar Wochen gesehen, bei der Firmware 2.3.0 als ich die Firmware für ein 1043er V4 angefragt und genutzt habe. Habe es aber auf den Browser geschoben und keine Bedeutung gegeben.

P.S. Aber die Version 2.4.0 läuft sonst im Test gut.


#9

läuft stabil auf nanostastion m2 und die weboberfläche ist in german


#10

Heute Abend wurde erfolgreich ein 841 v11.1 geflasht und der war deutsch.


#11

Evtl. hat der Browser in den betreffenden Fällen Englisch als Systemsprache übermittelt. Dann wird auch das englische Interface angezeigt.


#12

In dem Fall hätte die FW ja alles richtig gemacht.


#13

Ich bin dafür die beta zu machen, damit die angeblich kaputte 2.3.0 rausfliegt.


#14

+1 für Beta von mir.

Gruß Marius


#15

+1 auch von mir. Ich setze nachher mal die Symlinks.


#16

+1 für Beta


#17

Beta wird ausgerollt.


#18

Mein UAP Outdoor+ hat Probleme mit der Beta, ich meine bei 2.3.0 verlief der Test ähnlich negativ.

Die Verbindung ins Batman-Netz klappt, es hakt aber mit der Internetverbindung (Systemzeit wird nicht aktualisiert, Firmware-Server ist auch nicht erreichbar).


#19

Ist das ein reiner Meschknoten gewesen? Eventuell war zu dem Zeitpunkt V6 kaputt.


#20

Es ist ein Knoten mit L2TP-Anbindung, ist über eine WDS-Brücke mit dem ISP-Router verbunden.

Im Moment sieht es für mich nach diesem (oder einem sehr ähnlichen) Problem aus: Meshknoten in Telgte offline