Support Ubiquiti NanoStation M2?


#61

Ich greife diesen Aspekt noch einmal auf und kann einen Lichtblick vermelden: Was oben über das Webinterface nicht wirklich funktionierte, hat jetzt via tftp scheinbar funktioniert:

bash-4.2$ tftp 192.168.1.20
tftp> binary
tftp> put XW.v6.0.6-beta.30875.170526.0023(1).bin
tftp> q
bash-4.2$

Aktueller Stand, auch nach Reboot:

Firmware-Version: XW.v6.0.6-beta.30875.170526.0023
Build-Nummer: 30875

Die Hoffnung stirbt zuletzt…


#62

Super und was du jetzt vor


#63

Weiter mit diesem Vorschlag:

Hatte ich zuletzt durchgeführt.

Jetzt dieser Schritt:

Zuerst habe ich den Weg über das Web-Interface versucht. Hier gab es keine Probleme und dieser ermutigende Hinweis:

Hochgeladene Firmware-Version: XW.v6.0.4.
NOTE: It’s your own responsibility to keep your network secure after airOS downgrade.

Nur leider hatte das auch hier wieder keinen Bestand und es bootete die vorige Version.

Also habe ich es wieder via tftp versucht:

bash-4.2$ tftp 192.168.1.20
tftp> binary
tftp> put XW.v6.0.4.30805.170505.1510(1).bin
tftp> q
bash-4.2$

Hier kommt nach dem Reboot nun tatsächlich die eingespielte Version an den Start!

Jetzt der letzte Schritt:

bash-4.2$ sha256sum XW.v5.5.10-u2.28005.150723.1358.bin b222ae2fccd3a108cfc170197ca9b588048edf137846891b71ec863995bb7954 XW.v5.5.10-u2.28005.150723.1358.bin

Jetzt wird es spannend:

bash-4.2$ tftp 192.168.1.20

tftp> binary

tftp> put XW.v5.5.10-u2.28005.150723.1358.bin

Error code 2: Firmware check failed

WTF?

Edit: So weit war ich übrigens schon in Kommentar 17.


#64

Okay, interessant :roll_eyes:

Immerhin – die Nano läuft jetzt mit 6.0.4 (usigned), korrekt?

Was meldet das Webinterface, wenn du die 5.5.x einspielen möchtest?


#65
Firmware-Version: XW.v6.0.4

Build-Nummer: 30805

Es wurde eine falsche Firmware-Version hochgeladen. Bitte laden Sie die richtige Version hoch und versuchen Sie es dann erneut.

#66

Dann nimm eine 5.5.1.0 ab da aufwärts


#67

Auf jeden Fall, sollte man sie spüren lassen. Finde auch, dass du da jedes Recht zu hast. Aber vielleicht klappt es ja noch. Bei manchen TP-Link-Modellen musste man nur die Regioncodes richtig setzen.

Leider nein. Das hat die ITU verbrochen, obwohl sie explizit sagen, dass das nicht gewollt war. Sowohl die EU als auch die USA haben das nur übernommen.


#68

Habe nochmal erfolglos die Version 5.5.9 versucht, weil die im Video genannt wurde. Leider mit unveränderter Fehlermeldung.

Die suche ich noch…


#69

Das ist ja noch schlimmer.


#70

Jetzt ist es wieder platt. Im Anfall von Übermut/Verzweifelung habe ich es nochmal mit der FF-Firmware der Magdeburger versucht. Hat sich auch im Web-Interface scheinbar fehlerfrei einspielen lassen:

Hochgeladene Firmware-Version: XW.v6.0.0-OpenWrt-r49261
ACHTUNG: Die hochgeladene Firmware stammt von einem Drittanbieter. Bitte machen Sie sich mit dem Wiederherstellungsprozess vertraut.
NOTE: It’s your own responsibility to keep your network secure after airOS downgrade.

Aber danach ist alles tot. nmap meldet keine Dienste nirgendwo…:frowning:


#71

Hm, das Ding ist ja echt eine harte Nuss… Das schreit jetzt erst einmal nach einem TFTP-Recovery.

Diesen Beitrag habe ich noch gefunden:

Vielleicht ist es sinnvoller, sich das mal in Ruhe mit ein paar Leuten in der Warpzone anzusehen – und das Ding aufmachen und die serielle Konsole verbinden. Das macht die Arbeit deutlich einfacher, da man direkt sieht, was auf der Kiste los ist.


#72

Bin jetzt wieder auf XW.v6.0.4

Wenigstens das Recovery auf via tftp funktioniert verlässlich bislang.


#73

Supernettes Angebot! Aber spätestens dann ist Essig mit Zurückschicken, zumal man dafür auch erst mal einen Termin finden müsste. So weit bin ich noch nicht.

Vielleicht darf ich zu einem späteren Zeitpunkt noch mal darauf zurückkommen?
TNX


#74

Bin jetzt auf:

Firmware-Version: XW.v5.6.15
Build-Nummer: 30572


#75

Rücksendung bis zum 16.02.2018 möglich

Für heute ist Feierabend. Weiß noch nicht, wie und wann es weiter geht, aber heute würde ich maximal noch etwas final bricken.

Bis hierhin vielen Dank an alle Beteiligten, Ihr seid großartig!


#76

Von da sollte sich unsere Software einspielen lassen.


#77

Leider nicht:

bash-4.2$ sha256sum gluon-ffmsubibin
fba92f78c6bf187c68ec9250546a186301ce7e9c501f6c30df5d106836905d4e gluon-ffmsd51-v2016.2.6+2.6.0-ubiquiti-nanostation-m-xw.bin
b7cc4858b701655cccba7893379ca8619a0bd4995da42fc785c4cc6f413f0c7c gluon-ffmsd54-v2017.1.x+3.1.7-wr1043v5-exp-ubiquiti-nanostation-m2-xw.bin

tftp> put gluon-ffmsd54-v2017.1.x+3.1.7-wr1043v5-exp-ubiquiti-nanostation-m2-xw.bin

Error code 2: Firmware check failed

tftp> put gluon-ffmsd51-v2016.2.6+2.6.0-ubiquiti-nanostation-m-xw.bin

Error code 2: Firmware check failed

BTW: Auch die Magdeburger Variante hatte ich damit erfolglos getestet.


#78

Hab lange keine mehr gefläscht. Entweder das Ding hat eine Macke oder es gibt neue Sicherheitsmechanismen.

Mir fällt nicht mehr ein.


#79

Hinweis von kpanic aus dem IRC: Evtl. das Image mal in firmware.bin umbenennen.

Hintergrund: Hin und wieder machen längere Dateinamen der Images mal Probleme.

Weiter Hinweis: Versuch jetzt mal, das Image über das Webinterface zu flashen anstatt über TFTP. Klappt dann evtl. auch ohne das Umbenennen.


#80

Das hat keinen Einfluß. Es bleibt bei tftp in den beiden zuletzt genannten Fällen bei der Fehlermeldung:

Error code 2: Firmware check failed